Worldwide routable Garmin maps: URL REMOVED

Wouldn’t it make sense to do a complete reset and then accept new requests?
Who is the operator of the site?
Maybe it is just spammed because of all the requests…?

The problem is that Lambertus seems to be not responding to any queries.

For all those stuck in the waiting queue - there is a way around this issue - just select map type and tiles as usual, but instead of requesting the download, just look at the bottom of left sidebar - there are direct links to all selected tiles there - just download them all, and then use a tool like (I’m sure there are other more user-friendly if you don’t like the command line) to merge them into one gmapsupp.img file, rename it to gmapbmap.img, upload to your Garmin and you’re gold. Just tested, works fine. :slight_smile:

Great tip, worked perfectly for me too. Thank you!

I found MapWel Map Upload worked a treat to easily combine the tiles and load them onto a Garmin 520.

Had the same problem, gonna try the solution you’ve suggested here, hope it will help me

Have now received this message for several days.

"This request could not be found in the queue. Most likely the map is already generated and you received another email containing the url where the map can be downloaded, or you should receive that email shortly. "

But did not receive a link to download.

Have now created a map again.
Now in the mail:

This request is # 365 in the queue. The delay is approximately 18.3 hours.

I guess he deleted all requests because there were too many.

@bmw-biker007 It’s broken; you’ll need to use another source of maps. Lots are listed at (and you can also create your own).

Short feedback:

Now after the second generation, it worked very quickly.:D:D:D

And it is working fine now, Thanks.

I have been getting the message “Sorry, this service is currently not available due to server problems. Please come back later…” since last weekend. I gather this is an issue that pops up from time to time, but does anyone know when it will be fixed? I’ve tried different browsers and different computers but it does not seem to make a difference.


It’s broken, use a different site (there are lots that you can download OSM-based Garmin maps from). See GerdP’s post above and numerous others offering similar advice.

Isn’t there something missing from ? I don’t see where to put my email address, or how to download my selection, although I’ve successfully done this before many times in the past. Am I missing something obvious? David Reik, Farmington, CT, USA

Yes, seems the service is broken again. See previous posts for alternatives, e.g.

Hi Is anyone having an issue with some of the tiles the latest osm uk map. Some of them in the north of England do not display on my Garmin Edge when I zoom in closer than 2Km. I’ve tried both the pre-built uk map & a custom selection & neither of them work correctly. Cheers HD

This could be caused by multiple maps with duplicate tiles. Check it with Javawa Device Manager,

I only have the UK OSM map enabled on my device & none of the other maps have any UK tiles. It’s very confusing as the tiles I’m having the issue with are the tile covering my local area & another tile adjacent to it.

Other maps could have the same ID, they do not have to be enabled to mess things up. You can try to remove those maps to see if it gets better or try another map provider,

I downloaded the Javawa Device Manager & checked my device maps today. It did show that some of the disabled maps on my Garmin had overlapping tiles with my UK Map, though strangely there weren’t any overlaps in my local area where I’d noticed the issue.

I’ve removed the conflicting maps from my Garmin & the UK map tiles are now being displayed. I did think that if a map was disabled it wouldn’t have any effect on the enabled maps, but I guess my assumption was incorrect.

Thanks for you help in tracking down the problem. :slight_smile: HD

Good to hear that it solved your issue. Maps from different areas but from different updates can have identical map ID’s. So they don’t need to overlap the same area to cause a conflict. And as I mentioned, when they are even disabled, they still can cause conflicts with enabled maps.

I had the same problem when using Internet Explore. Switched to Chome and it started working for me.:slight_smile: