Worldwide routable Garmin maps: URL REMOVED

Thank you. It looks like it is exactly, what i’ve been searching for.

there is a problem with a title. It is the one in Indonesia, located in southeast Borneo/Kalimantan (Samarinda/Balikpapan) and goes to northwest Sulawesi (Palu/Majene). I had downloaded the mapset in April. When I got to the area, all scales smaller than 8km are blank and no navigation is possible. If I’m outside of this title, everything works fine. I thought, maybe something went wrong with the download or the conversion and gave it a 2nd try yesterday. The map creation finished within 5 minutes, but when I uploaded it to my device, the same problem occurred. Is there a chance, that this will get fixed, or do I have to switch over to Google for this area?

Looking at the latest generic new style map for Indonesia, I dont see anything wrong with this tile.
Are you sure you don’t have multiple maps on your device with the same tile number?

Ahm, sorry for the missing information, I’m using Generic Routable (old style). I’m pretty sure, there is no other mapset containing the same number, because on this device (Nüvi 1350) you can run only one gmapsup.img and the only other mapset, that is installed, is the one by factory (Europe 2011).
It looks to me, like the overview map is converted correctly, but the detailed maps below are missing or corrupt

Just checked the generic map on my old nüvi, don’t see any issues with that tile either. Please try the Generic new map or include the mapnik typ file, maybe that will help?

Just wanted to say thank you for fixing the whole queue thing, I appreciate it.

Just wanted to report, that the new version solved the problem

Hi there, first of all I thank you for the work done on the garmin maps, it is really impressive.

I have a problem with routing in OSM between two points separated for more than 200km (approx) apart. If the distance between the routing points is larger than approx 200km then basecamp shows a straight line when using driving, motorcycling, ATV but not when using hiking, mountaneering, etc. On Garmin device it says there is no route between the two points in the same situations.

I use the OSM on basecamp and then download OSM maps from basecamp to my Garmin Zumo 595 LM that is subsequently mounted on my motorcycle. I saw the problem first time when I downloaded the Iran map last year. The workaround I used on the field was to split the route in several shorter routes but it needed me to stop driving and look on the paper map for one or more intermediate points.

I thought the problem was only for Iran map but last night I downloaded a map for western Russia, Belarus, Ukraine, Romania and tried to make a route. The same problems remained even though I installed basecamp 4.6.2 (the latest version) and after that I went down to versions like 4.4.6, 4.3.5, 4.3.1 to see if the problem still occur. And it does, none the less.

I am using basecamp on windows 7 and it runs in a virtualbox machine, if it does matter related to the problem I see.

I may say that OSM was great for my trip in Iran last year, very detailed and precise and it showed the gas stations along the route which was of really help especially in the desert. Great maps.


The first time I have

A note to those who haven’t received an e-mail:

You will get two e-mails, one immediately after you put the request into the system,
another one when the job has finished.

If you did not get the first mail, chances are very high that you will not get the second!

Check that you really entered a correct address, check you Spam Folder and Spam setting and if all that still doesn’t help, use a different email provider. Gmail for exmaple always worked fine for this service.

There is a surprising high number of false e-mail addresses which cannot be delivered (34 at the moment on sn21 alone, haven’t checked the others). Generating these maps took time and the requests are lost now. So please double check your mail address and refrain from using any false ones like You really need the link in the mail to use this service, so if you don’t like to put in your mail address, please use another service. We don’t save your addresses nor give them away to anybody.



I use to have routing problems on longer routes in Europe, nowadays It poses a lot less problems as the little details get fixed.
Usually the fastest is a better algorithm to deal with these problems.
Otherwise add routepoints in between and fix the map where it is broken.

There has been no map update since 10th June. Does the server need a bump start?

Some difficulties installing maps:

  • Windows defender warning >>> Ignore
  • AVG warning that file is suspicious >>> Ignore

File wouldn’t install due to insufficient rights.

In settings of AVG adjusted ‘suspicious files’ to decide myself and file installed successfully.

Others having same issue?


Yes Ed, unfortunately a lot of anti virus programms detect the installer as suspicious.
You can ignore those, and please submit those false positives at AVG or Windows.
If you can’t ignore it or doesnt trust it anyway, you better install the Mac/gmap version (also for windows users, doesnt need an installer).

Hi, is there an issue with the latest Openfietsmap Lite United Kingdom tiles (31-07-2017)?

The rendering has gone completely wrong. For example major roads are shown as cycle routes, all paths are rendering red as cycle tracks. Farmland background showing a question mark.

I have tried individually selecting tiles, with the same issue and making sure previous versions were completely removed. The rendering issue happens on both basecamp and the Edge 1000.

Locally installed on my PC with windows basecamp map installer, placed IMG file onto SD card for used with Garmin device.

The issue happens with all other maps disabled, and in basecamp with the Garmin disconnected.

I’ve put a screenprint of the map to: - The red lines in this screenshot are footpaths, only the longer path at the lower right has the tag ‘cycles=yes’.

It sounds like the typ file is missing or has an ID that does not match with the map id. I am not able to check it nor fix it, but you can try to correct the installed map on your pc with If GMTK is able to repair it, you can generate a new mapset for your device with Basecamp.

Thanks I will try the software later :slight_smile:

Could this become a regular issue? I am always downloading small updates about once a month for around 2 years (I’m a frequent mapper in my area). I havn’t experienced anything like this before.

No, it should be an error in the map compilation process. I have checked a small mapset (Malta) and the typ file seems ok, but the rendering looks like it does not read the typ file at all. This could not be fixed with GMTK. Could be a mkgmap bug too (maps are compiled with r3972). I have no idea to fix it or where this error comes from, I’ll investigate it further, thanks for reporting!

If it helps, I’ve noticed that all buildings are showing. Usually on the lite version I see that only named buildings display.

Tried the GMTK software but it showed there was also nothing to repair.

Have tried a previous verison of the Lite map, works perfectly.

Good find! I think the OFM style is not processed but instead the default style is taken. What you get is the default style with the wrong typ file, resulting in this mess. I’ll ask Lambertus to check and fix this, thanks again.

Lambertus confirmed it was a configuration error on the server (instead of the OFM the generic style was processed). A fresh map is being compiled now.