Worldwide routable Garmin maps: URL REMOVED

Please post the link to your map. Thanks!

same problem here for the second time - had this problem 2 or 3 weeks before.

First available download contained only the tiles - tried to build a custom map for two times: got only tiles and gmapsupp-files of 22KB(!)


Same problem as previous poster. I tried a number of time yesterday and today with tw different maps. Here is what I get – img file missing:

Tried once more just now:

Some problem again:

same problem again - no chance to get a working map nowadays

Thanks for the links. Those are not the same problems though. The last one looks like php crashed because there is no buildlog.txt at all. With others Mkgmap seems to have given up because of ‘exit exception’. I’ve added extra logging and hope it will reveal something.

BTW. I’ve just browsed through the maps and the failure rate is (guesstimate) far below 10%.

Thanks for your help Lambertus!

Exit exception:
Time started: Mon May 25 13:48:36 CEST 2015
Number of MapFailedExceptions: 0
Number of ExitExceptions: 1
Time finished: Mon May 25 13:48:37 CEST 2015
Total time taken: 1122ms

@Lambertus, looks there is something going wrong during the process

Can't open script "63240000.nsi"


Building Basecamp/RoadTrip installer
JaVaWa MapConverter CLI version 0.7

Error: basemap doesn't exist

This is only a secondary problem. Mkgmap fails to generate a gmapsupp.img and, because in the same step the .nsi script is generated, the subsequent attempt to generate the Windows Installer fails because the .nsi script is missing. So the root cause is something in Mkgmap, unfortunately the extra logging does not contain the Java stack trace. Looks like I need to include more into the logging then stdout, so I’ll explicitly add stdout and stderr as well.

Please keep posting the links to failed maps please! :slight_smile:

Still no luck:

The files is there but 22 byte is not a very detailed map.

Same story:

My two submitted requests where similar in content, and it seems that the machinery gave me to identical links to maps generated May 19th (likely generated on my earlier request).

Here is on more: Still The files is there but 22 byte and still dates May 19th


Thanks! The better logging provides a clue to the problem this time:

The directory “mapnik” is deprecated so that needs to be fixed. For now I worked around this by adding a symlink. This should be fixed now (on the sfs4 server).

Yes, it looks like this problem is solved now. :slight_smile:

Thanks all for reporting/feedback and suggestions!



Dear Sirs,

My location was in Hong Kong and I download the file to use with my Garmin. But it was only show english language.

I would like to have a map with local language (Tradition or Simple Chinese are ok)

Would you tell how to select this option during create the map for download?


David, that is not possible, the maps are only available in English.

Thank you very much.

Dear Sir,

but how come I got local language when update the map such as link below?

Or your meaning is when extract to img file, the data only could be available in english?

Thank you very much.

(sorry as I am newbie and may be ask for foolish question)