Worldwide routable Garmin maps: URL REMOVED

I am trying to install a map (Generic Routable) with mapnik style. The typ file is included, but seems to be ignored: All features show up in Garmin default style, e.g. forest as red horizontal hachures.

I have also investigated the family IDs, but don’t see any obvious problem there. The typ file is named 2000.typ, has id 2000 according to, and the corresponding key ID in the windows registry reads d0 07 which seems to be matching, too. Does the mapnik style work for everyone else?

It should work, perhaps you can try to empty the cache (ctrl-G 2x)?

Funny enough (as it was a very fresh installation I would not have suspected to cache anything yet), that did the trick. Thank you ligfietser!

¿The scripts or mkgmap options and styles used to build the Lambertus are public?
I’m triyng to investigate why i’m seeing different routing and routing indications behaviour between Lambertus’s map and others.

Here you can find the styles:
Generic Routable =default mkgmap style
Generic Routable (testing new style)

Maybe Lambertus can post the mkgmap parameters, or you can search earlier in this topic.

The scripts aren’t public. Not because I don’t want to share them but because the scripts are very specific for the setup of servers I’m working with and I don’t have the time to provide support for anyone who wants to get the scripts working. I’ll be more then happy to supply the scripts to anyone seriously interested though, just send me an email.

The styles are public:
Generic normal & Generic with Mapnik style: standard Mkgmap styles
Generic new & OpenFietsMap Lite:

I should provide easy access to the Mkgmap options but haven’t done that yet. I copied them below:

Tile rendering step for the Generic map:

$name = "generic";
$description = "OSM Generic Routable";
$family_id = "2000";
$product_id = "6";
$mapid = 63240000;


Map building step:

$description = "OSM generic routable";
$underscored = 'osm_generic';
$family_id = 2000;
$product_id = 6;
$overview_name = "63240000";
$copyright = "'Map data © and contributors'";

= "java -Xmx6144M -jar $utils_dir/mkgmap/mkgmap.jar";
--gmapsupp 63*.img ovm_63*.img 

Thanks. The mkgpamp options is all i need to start.
I let you know if i need other details like mkgmap revision number.

You can find the mkgmap revision number in the license.txt file (in the download link) or in Mapsource under the copyright notes (ctrl-U)

Hi, I’m having a problem installing 2 ‘OSM generic routable’ maps side by side. Google isn’t being helpful, although it did direct me here.

This is what I’ve done so far:

  1. Downloaded and installed the ‘OSM generic routable’ map of United Kingdom from

  2. View map in Mapsource. Map works fine. Close Mapsource

  3. Used JaVaWa latest version (3.5) to change FamilyID (2000 => 2044) and Name on Computer, Device and Folder all to ‘OSM GR UK’

  4. View map in Mapsource. Map works fine. Close Mapsource

  5. Download custom ‘OSM generic routable’ of Ontario (manually selected some additional tiles)

  6. Attempted to install the Ontario map, error displayed by the Installer is : “OSM generic routable is already installed. Click ‘OK’ to remove the previous version”.

At this point I cancelled as I don’t want to trash the UK maps already installed.

I can’t figure out whether I’m doing something wrong here, or if we have a problem. I’m familiar with Garmin maps, registry settings and so on, and I’ve checked the registry after JaVaWa does its thing and the changes have been applied as I believe to be correct. I don’t have any other maps in the registry with FamilyID of 2000. JaVaWa does not report any conflicts or problems with the current map set up.

Any ideas what to try next?

I think it is only installer problem. Install new map manually or move old map to other director and correct registry entry accordingly.

GMTK already did that. Just click ‘OK’ and proceed. The uninstall process will remove the some installer stuff, but not the map (because it isn’t there were the uninstaller expects it to be).
To be sure you could create a backup of ‘OSM GR UK’ with GMTK; in the case that the uninstaller manages to remove some vital information, you can always restore the map from your backup.

The problem is that the installer doesnt know that you have changed the settings. I think it is fine if you click on OK when the message “OSM generic routable is already installed. Click ‘OK’ to remove the previous version” is prompted, I think nothing will be removed because you already moved the maps to another folder?

Maybe Javawa can have a look and remove the installer when someone has changed the WR maps to another location with his tool?

Edit: he already answered :wink:

I’ve decided not to mess with installers in GMTK, because every installer works differently… In the past this problem didn’t occur with the OSM installer, but at some time a check for a previous version was added to it. Maybe you guys could add another check (whether the previous map is still present at the original location)?

Thanks guys, I didn’t think to try just clicking OK :roll_eyes:.

I’m sure that would have worked, however, I thought about it over lunch and decided it was just a problem with the installer too. So what I did was to rename the registry key at:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\OSM generic routable


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\OSM GR UK

then the installer worked fine.

Here is the code, anyone who can do a good suggestion please let me know

Please advise. Sorry if you need to explain this over and over again to novices like me.
I have just downloaded some European maps with the installer for Windows. The installer apparently unzipped itself into a bunch of IMG files. I have no idea what to do with them next to make them work. My Garmin Nuvi has a micro SD card; I copied the files there into Garmin directory, but, not very surprisingly, it was not sufficient to show the maps. Now I’m stuck. Is there some instruction on how to make these maps work? Could you please point to it?

The imgs that you have installed are not intended to put on your gps, look for a separate gmapsupp img that is listed in the download links that you have received in your mail.

Thank you very much. Indeed, I overlooked that gmapsupp file in the download. Now I see the difference - streets and POI became available in the area I am going to visit. I assume that I don’t need to do anything more, and my GPS will be able to navigate using those maps when I arrive to the place.
One more question if you don’t mind. If I want to add more tiles to the map I have, should I start over and pick the new tiles, as well as the old ones, and download all of them, or is there a smarter way? I don’t care too much about my time, but I want to avoid extra load on OSM server if possible.
Thanks again.

Yes if you want to add new tiles the usual way is to do a new request. There is another way but this involves a merging of tiles with mkgmap, which can be done automatically with Javawa OSM Combiner, but this can only done if the map tiles that you already have are from the same date as the new ones that you want to add. Javawa’s combiner is meant for combining large mapsets ( > 2 Gb)

OK; thank you. I’ll request it again then - for multiple countries this time.