Why hotel´s name change does not appear on OSM?

I would like to ask if anyone has an idea why the change of the name of the hotel that I have made in OSM is not displayed. Two hours have already passed, I have cleaned the caches and nothing.
The original name was Ollantaytambo Lodge but several months ago it changed to Hotel Lilium Valley Ollantaytambo. I am trying to fix the name on the map but it does not work.

Gear set numbers are: 133638052 and 133637910.

I would appreciate any help.

1 Like

Hello Petra and welcome here!

Your renaming of the hotel did work for me: Way: ‪Lilium Valley Ollantaytambo‬ (‪530632256‬) | OpenStreetMap
I need at least zoom level 18 to see it on the standard map.

If it doesn’t work for you, can you please post the hyperlink that you are using.

Best regards

1 Like

Hello Vinzenz,
thanks a lot for your response. I can still see the old name on the map (see screenshot attached). You can see the new name?

Sorry, I am not sure what you mean by hyperlink that I am using. I am simply viewing the OpenStreetMap of Ollantaytambo and I keep seeing the wrong hotel name.

Really appreciate any help with this.
Kind regards.

Sometimes it simply helps to clear/refresh your browser’s cache.

Ctrl-R or Ctrl-F5 could be your friend - maybe you have to repeat that few times.

1 Like

Thanks, I´ll keep trying. I deleted caches a while ago but still nothing. I´ll try in different browsers as well.

Curious how Crtl+F5 does work for me as a fresh data pull, noting that the 2km view and lesser magnification only refreshes on friday night, 1km view and greater magnification refreshes in minutes, with Ctrl+F5 on Windows.

1 Like

I have tried that option too Ctrl+F5 and it worked, yupiiii.
Thank you, everyone!!

N.B.: as background information: On some maps (e.g. osm.org standard) tiles/images get rendered on demand. So, they get re-rendered when someone wants to see them and data has changed.