Why can't I view the map?

For the last few weeks I have been unable to view the OSM map in normal viewing mode, yet I can open it up without any problems in Edit mode. I can view the map from my work computer but never seem to be able to get it at home. JOSM works ok. Occasionally I might get one or two tiles and that’s all, at any zoom level. Clicking on refresh doesn’t help. Anyone got any help or tips?

Problem solved!
I change the browser from Google Chrome to Internet Explorer and now it works. How did I discover this? I couldn’t access my bank account in Google Chrome. Change back to IE and it’s ok. Google obviously needs to sort out some bugs.


Google Chrome is beta software, google says. So yes, even Google thinks it is probably buggy :slight_smile:

That’s true, but I’m just making sure everyone else is aware of the problem.

I solved the problem. I use a Belkin modem which has antivirus software built into it. Since de-activating the software I can download the tiles in Google Chrome. It’s still a bit strange that it didn’t bother Internet Explorer. Anyway, it works now and that’s all that matters.

The method IE uses is probably an older, more established way of doing things. Chrome, Firefox and Safari live at the bleeding edge of software developments. :slight_smile:

Alex, More like MS’s non standards compliant way of doing things and IE specific technologies which causes problems with other browsers when pages are developed for IE. :slight_smile: Banks used to be bad for this and the online tax systems (ATO) were useless to me being a Linux user.


Hey don’t confuse me for an MS apologist, I’m a web developer and I have had many hours of pain from IE’s lack of support for standards. However it’s true that Firefox and Chrome are now implementing standards which aren’t finished (CSS3, anyone? HTML5?).

The point I was making is that antivirus software is written to not interfere with finished, well established standards (like HTTP). If the newer browsers are using HTTP extensions then that could explain why they were affected. :slight_smile:

Ahuh :slight_smile:

Meanwhile first question to this topic came years ago. But I’ve got same problem. I have been using OSM with Internet Explorer for a long while. Some time start page looked strange. At least with IE8 I couldt not see a map anymore. There were a top line, a bottom line and an input windows for a search word on an empty screen.
Shortly I installed Chrome (actual version 23.0.1271.97m). Now I can see a regular start page. I can see a regular map too. But when I zoom in, the view loses tiles. When I zoom out, other tiles seem to be missed.
I am using Win XP SP3 and a 32 MBd cable connection.
Can anybody give a hint?

Sometimes the tile server has trouble in delivering all tiles when server is under maintenance or has high load. Try again some hours or a day later …

do you have a correct display when using openstreetmap.de or openstreetbrowser.org ?