Western Australian maps aren't being updated.

Having downloaded the latest map of Western Australia from the free Garmin site run by Lambertus I was annoyed to find that changes I made a month ago do not appear in the maps. Thinking that maybe Lambertus might not be updating the data regularly for his builds I tried the map from the OSM Australia website which is supposedly updated nightly. Once again it doesn’t appear to have been changed for nearly a month. Can someone investigate and see what’s going on? I opened the files with GPSMapedit in case there was a problem with my copy of Mapsource, but the result was still the same. Can someone have a look please?


Edit: I went through things again and I found the updates DO appear in the OSM Australia maps, I must have had opened an older map, additionally, I downloaded the gmapsupp.zip file from the Lambertus site and the updates were in there too. So the problem seems to be that the updates don’t appear in the EXE version from Lambertus site, unless for some reason when the install takes place it uses an older version of the same file. I’ll have a fresh look later when I have more time.