Weird problem with style file


I am building my maps with same routine just using latest splitter and mkgmap.
Now I don’t see same map in qlandkartegt and in my Garmin unit.
In qlandkatregt map looks as expected but in Garmin it looks like just some default style file and TYP file was used and not main custom one.

Here is my commands:

java -ea -Xmx6144m -jar mkgmap-r2459/mkgmap.jar test19.TYP --precomp-sea=/media/MEGA/MAPING/sea --bounds=/media/MEGA/MAPING/bounds_20121230 --style-file=default-mira -c default-mira/arguments LAND/6324*.osm.pbf CONTOUR/contour*.osm.pbf

Argument file:

family-id = 2222
product-id = 1
mapname = 22220001

family-name = Czech
description = Hiking map of Czech
country-name = Czech
country-abbr = CZ

max-jobs = 2

I checked if FID and PID in argument file and TYP file are matching and they does.

Any idea what might be wrong?


Maybe it helps if you put test19.TYP after all the other parameters?

That’s make a trick!
Many thanks!

BTW I am editing my TYP file in TYPviewer and there are some options for header size.
What header size is recommended or it doesn’t matter?



Please note that qlandkartegt selects the TYP at runtime - whichever *.TYP file is found in the same folder as the map proper, can be selected to display the map; you can also view your map with different TYP files without the need to create it again.
With Garmin, the TYP file has to be compiled into the map, it becomes part of the map. I normally use gmt.exe for that purpose.

With TYP files, the higher the header the more extra information is included, ie sdk references,extra commercial icons or active routing. If your TYP file does not contain such information you can just stick to &5B to save space.
For more information see my typformat.pdf

Right. My problem was that I was not aware that my custom TYP was not used during building a map due bad position in front of parameters.
Maybe it would be useful to have some warning in mkgmap for this situation.
Or maybe just print information during building a map which TYP file was used.

I am building my maps on Debian so I am trying avoid native windows apps even it is sometimes possible to use them.

thank you


You can try linux version of GMapTool:

Ok thank you.

I am using just symbols from this document… starting on page 107 … :

Does it mean that I dont need extra POIs and I should be fine with old header (91 old format )?


You are fine with the old header (91 - &5b)
This would allow for all your usual POIs, as in page 107

The ‘extra pois’ are generally used in some NT TOPO maps .
They tend to be commercial logos but could also be famous 3d landmarks or buildings.
Because they require a different. not fully understood, (NT) img structure, such POIs are at present not supported by mkgmap or cgpsmapper.

Thank you!

I have one other issue with POIs.
Although I now build my map correctly with my TYP file I still see on some places POIs icon which are not made by my TYP file.
These icon having same graphical style as on map which I build accidentally without my TYP.

I was checking these places on osm with Potlatch, but there is really nothing!

Any idea what’s going on?



Maybe those pois are created by mkgmap from areas, do you have --add-pois-to-areas in your options?

Yes, I am using --add-pois-to-areas. I will try build map without --add-pois-to-areas to confirm this a problem.
But I would like to use --add-pois-to-areas … this argument helps me add names for small islands to my map.

Or exists some tricky way to add pois just to some areas e.g. islands?



Yes, those artificial points gets a tag mkgmap:area2poi=true

For example, if you dont want a poi created from place=city polygons you can add this rule in the points file:
place=city & mkgmap:area2poi=true {delete place}

Or, if you have --add-pois-to-lines you can add for example this rule in your points file:
amenity=* & mkgmap:line2poi=true {delete amenity}

I removed --add-pois-to-areas and --add-pois-to-lines too but these foreigner POIs are still there :frowning:



If you say that this icons are not from your TYP file, I would go through your style files and compare them with your TYP file, which rules are using IDs which are not in your TYP file.
If you found your rule, we can tell you what happens.
mkgmap does not add POIs which are not listed in your style file. So there must be something wrong, maybe a number written wrongly.

Else this POIs are not coming from your map, but you have a second map or a gpi file on your device, from which this POIs are coming.


I have just osm map anabled and garmin base map disabled. I never loaded any gpi files intentionally … but anyway I was searching for them and didn’t found any.
I also removed all gpx files.

But still same.

I was checking my points and TYP file quickly and will do more later … but nothing found. I am building map without --add-pois-to-areas and --add-pois-to-lines so probably only point file can produce this issue.

I was also checking osm map if there are some entries on these places but really nothing is there.
And interesting is that these icons are not on all places but I can see them just around Prague airport area.

Here is screenshot from my unit:

  1. picture …anchor and green dots
  2. picture …no icon is mine excet left down black square
  3. picture … “scales” “green fish” and something orange
  4. picture … orange flag

my points and TYP file can be downloaded here (mira-typ.txt is my TYP file):


Try gpsmapedit to see what kind of garmin types those mysterious pois have, you can also see if those pois are in your osm img file, maybe they are not even in your osm file at all.

I checked tile where these pois should be with gpsmapedit but nothing there again. :frowning:
Also I think that if I would have problem in points file rules I would get these problems on more places and probably not so many different kind of icons.



Well, that means those pois are not from mkgmap and OSM!
It must be from your background GPS map or other maps on your gps so there is nothing you can do about it with your style and typ files.

There is maybe another solution, do you use a background polygon? If you have one, the pois from other maps are not visible anymore.
I think the default is 0x27, you must give it the lowest priority (1) and a bitmap colour.

I’m just trying solve this issue with background polygon.
I think it should be 0x4b. I made it “white” in my TYP file, but I am not sure if it was builded into my map.
It should be defined somewhere in polygons file? Or there is some mkgmap argument?