Warning: do not update Basecamp! [Solved]

I upgraded to Basecamp 4.6.3 but that doesn’t cure the no showing of installed OSM maps. Garmin maps show without problems. Is Garmin preventing use of OSM maps in Basecamp in some other way?

Worked fine thanks. And I backed up my old Garmin Basecamp so managed to retrieve all my track and route data with no risk.

Thanks again for the help. Your online routeable maps are great.


Bob Allen

No (at least not yet) :wink:
Try http://www.javawa.nl/gmtk_en.html to check if something went wrong with the installed maps.

Bedankt voor de tip ligfietser! Thanks for the tip! Indeed, I seem to have overlapping names. Is it possible to download additional OSM maps and give them an other name than “OSM generic routable (new style)”?

Polimo, yes you can do this with GMTK, in the menu “Extra”, you can change the name of the map and important, the family ID (submenu kaartnaam en ID wijzigen). The country sets already have an unique name and ID but the custom maps always have the same one.

Fantastic, heerlijk! Dank ligfietser!

I have tried numerous times to download & install basecamp 4.6.2 from the list provided but I keep getting an error message:

BaseCamp MSI Error: InstallFailure

Does anyone have a suggestion on what is wrong & how to fix it? thanks

I don’t know any solution but maybe this helps: https://forums.garmin.com/forum/mac-windows-software/windows-software/basecamp-aa/113082-


See also the tutorial on openmtbmap.org

Having read these posts I now realise that the problems I had when I upgraded to Basecamp 4.7.0 were not due to anything I did.

I will try the advice given above to blackout the latest version. However does anyone know if Garmin are going to correct this problem anytime soon and bring out a v 4.7.1 or 4.8.0 as this seems to be a reputation damaging glitch.


I dont think they are doing anything about it, maybe they dont really care because it does not affect their own maps.
Maybe they think more people will buy their maps instead of “corrupt” free OSM maps?
I really think it will harm their own business, people will ignore garmin devices more and more and will use smartphones.

According to this article Basecamp development has been discontinued:

They will now work on a webbased application called “Explore”

All people trying to be in the “cloud”. Nothing in the computers… your software, where/when you want!!!

Thank you! Uninstalling 4.7.0 and installing 4.6.2 fixed the problem.

Thank you so much - this was driving me mad!!

I have now installed a map of Valencia to my etrex 20, ready for a trip on Monday.

Thinks for the hint.

Unfortunatly for me it was too late. I successfully installed the older version now as recommended but face now two problems:

When I wanted to transfer a map to my GPS it refused to word because of a “wrong language DLL” on mapistall. I reinstalled an older version as recommended. The error remains and comes up as I start Mapinstall. What else can I do?
Found a workaround using the good old Mapsource but I’d prefer to keep using Basecamp.

Next problem I’m facing is when I wanted to recover my data from a recent backup file. It appears that in certain folders only data way before 2019 are reinstalled. I’m not sure though if something got missing when I did the backup or if the problem is related to the now installed Basecamp but I checked with an older backup with same results. Any ideas?

Thanks folks

Better uninstall everything and install the latest Basecamp; Don’t work with those windows exe mapinstallers anymore but install the gmap versions. Those don’t have those issues with Mapinstall (see also this topic https://forum.openstreetmap.org/viewtopic.php?id=65669))

Me thinks this is all about one thing: stealing, taking, copying, pirating, spying on, your data. I’m not sure why they would want to do this (I can think of a dozen from plain greedy to conspiracy theories) but I’m sure that is the reason behind these @#%$&! web-based apps! Hate them!

And that’s my first post.

On startup Basecamp 4.6.2 always nags me to upgrade to 4.7 Is it possible to get rid of that?