Warning: do not update Basecamp! [Solved]

After years, Garmin has released a new version of Basecamp, 4.7.0
This is not an improved at all, Garmin only removed features and introduced a serious bug:
Maps that were installed within the windows register (by installer or setup.exe) and are transferred to the GPS with Garmin’s Mapinstall, are not readable on the GPS! So do not update to 4.7 and stick with the old version 4.6.2.
If you already have installed it, just uninstall it and download the old version here: http://www.gawisp.com/perry/mapsource

Update November 2019:
Garmin has solved this issue with version 4.7.1.

Thank you.

It is actually MapInstall, which got a bug. BaseCamp probably had some spying features removed, at least I think this is the case with change described as “Updated BaseCamp to conform to GDPR requirements”.

Current MapInstall sends overview map instead of detailed tiles. Probably it would be enough to preserve previous version of MapInstall.exe and restore it after update.

Thanks ligfietser,

Yesterday i found lot off problems and then i say your message in this forum. I downgrade base camp and all things are fine now.

Graag gedaan Fred.
For gps problems and new garmin updates always check forum.gps.nl you never know what to expect :wink:

Unfortunately I updated Basecamp before seing this.
Is there a place where I could download Mapinstall 4.0.4?
I would assume that it does not have the bug?

De link is in the first post http://www.gawisp.com/perry/mapsource/

I should learn to read. :slight_smile:

Remove/re-install MapInstall 4.0.4 did not work.
I had to do the whole thing (uninstall all and reinstall older Basecamp)… But I’m back in operation. Download works again.

Thanks for all the help here!


Well, it was a good question, reinstalling an older Mapinstall was not such a bad idea. Unfortunately this shows that this issue also included Basecamp itself. Unbelievable that they still haven’t fixed this until now, they just seem they don’t care.

here is what I experienced. perhaps it helps

  • uninstalling mapinstall 4.2
  • installing mapinstall 4.0.4
  • starting mapinstall, it still shows as version 4.2 (?). perhaps there is a component or dll that is reusedfrom basecamp 4.7.0
  • copy maps to device
  • uninstalled basecamp 4.7.0, mapinstall was not uninstalled.
  • uninstalled mapinstall
  • installed basecamp 4.6.2, mapinstall was not installed
  • installed mapinstalled 4.0.4
  • mapinstall would not start with an error about a missing language dll
  • sfc /scannow did not fix
  • uninstalled mapinstall, uninstalled basecamp, reboot
  • installed mapinstall 4.0.4
  • installed basecamp 4.6.2
  • all working again fine…

I learn to read as well :D, but I cannot figure out where to find Mapinstall 4.0.4 in the "perry"link ( i do see Basecamp 462)

As such, please advise where to find the previous Mapinstall 4.0.4.


As advised:

I have completely removed the latest Basecamp version 4.7.0.
Runned CCLeaner to get rid of any unwanted registerlinks (if)
Installed Basecamp 4.6.2. which I downloaded from http://www.gawisp.com/perry/mapsource/
Luckely, after a while, all existing stored Routes, Waypoints and OSD-Maps re-appeared as normal.
Succesfully runned Mapinstall to install all tiles of the selected OSD map on the Garmin device.
@ ligfietser: Thanks for the guidance.

Oh boy. Took me a while to figure this out (thanks Google :slight_smile: ), after trying partial installs, combining maps etc. I also think MapInstall might be the culprit, since I first tried to install the latest version (4.2.0, IIRC), and that one is also broken. Then I downgraded Basecamp to 4.6.2 and still maps were not properly installed. I had to uninstall MapInstall for map installation to work again.

It’s interesting that, if you install a map with the broken version, and then you check what’s installed with MapInstall, it seems to show one tile from the whole map.

Thanks for the great info!

I’m having the same problem as others. I uninstalled BaseCamp 4.7.0 and re-installed 4.6.2, but the problem persists. I assumed that when I un/re-installed BaseCamp, it would automatically un/reinstall MapInstall, but perhaps not from what fencekicker says. How does one un/re-install MapInstall? It’s not listed in Windows 7 as an un-installable program.

(BTW, I took some screenshots to illustrate the problem but can’t find any way of attaching them.)

Thanks for any help!

Uninstalled BaseCamp 4.6.2 then manually deleted C:\Program Files (x86)\Garmin, then reinstalled BaseCamp 4.6.2. This worked, creating a new C:\Program Files (x86)\Garmin\MapInstall directory. I can once again install maps in my Edge!

I’m experiencing the same problem. However I need to access Basecamp 4.6.2 for Mac OS. The link in the first post is for Windows versions. Does anyone have a link for the Mac version? Also i have a several years worth of tracks/routes/waypoints connected with my current Basecamp application. Will these be retained when I uninstall Basecamp 4.7.0?

Grateful for some guidance

Here you can find the files for Mac: http://gawisp.com/perry/macintosh/ (4.6.3. is the former version).
Uninstalling won’t affect your data, at least for the Windows version, I assume it is the same for the Mac but I’m not sure.

I have the same problem with not showing installed OSM maps in latest Basecamp 4.2.4 in macOS. Is there a similar solution somewhere for Mac? A place to download older Basecamp versions? Thanks in advance!

The version you have is already many, many versions behind, so I doubt you need an even older version. You could try updating to 4.6.3 to gain the benefits of the various revisions that have been made since 2013 and still avoid the issue from the latest version.

Hmmm, remarkable! I was not aware. Thanks for making me aware. When I scan for updates in Basecamp it says “No updates available for program”
Still… the problem of not showing installed OSM maps may not be Basecamp related but Garmin MapInstall or Garmin MapManager related?