Upload with Merkaartor - wrong URL?

I am running Ubuntu 10.04 and have recently updated from Merkaartor 0.14 to 0.17 .

The old version worked fine, i could download data, edit it and upload it again to the OSM database without troubles or special settings needed.

Now the 0.17 version works almost as well, downloading and editing is just fine. But i couldnt upload anything, when i try it i instead get the error message below:

There was an error uploading this request (404)

404 Not Found

Not Found

The requested URL /api/0.6/changeset/11730472/upload was not found on this server.

Apache/2.2.22 (Ubuntu) Server at [www.openstreetmap.org](http://www.openstreetmap.org):p Port 80 " Please redownload the problematic feature to handle the conflict.

Either there is something wrong with the Server or (more possibly) there is something wrong in the configuration of my installation of Merkaartor. Most possibly the URL needs to be changed.

Has someone the correct data?

I’ve been using version 0.17 for a while and I just noticed the problem today. Looks like maybe OSM changed it’s upload URL and merkaartor (which doesn’t seem to be actively developed) hasn’t updated this.

I have the same issue since some days on Debian Testing (Wheezy) with Merkaartor 0.17.

However, everything still works fine on Debian Stable (Squeeze) with Merkaartor 0.16.

The Debian package for Merkaartor has not changed in the last days so the issue must be somewhere else (ie either on the server side or in a dependency of Merkaartor)
@Sat: which distribution are you using?

I’m using Arch Linux with version 0.17.2 of Merkaartor.

This must be some change on the server side of things since I haven’t done any updates since it was working fine a couple days ago.

Good news

I found some explanation on http://lists.openstreetmap.org/pipermail/merkaartor/2012-May/date.html

It seems that it was the combination of an old bug in Merkaartor and an configuration change on the OSM servers which disabled their workaround. In the recent hours they changed it back and my test upload a few minutes ago worked again. Now i can edit the rest of the data in the afternoon and upload a lot more.

I dont crave so much for the newest software versions, Merkaartor 0.17 is already good enough for me (except for multipolygons which are an problem of their own).

Happy mapping!