Update only visible in editor

Earlier today (about five hours ago) I used the GPX track from my GPS to add a new section of cycle path that has just been opened. I can see the change when I’m in the editor (http://www.openstreetmap.org/edit?editor=id&changeset=53467064#map=18/-35.18125/149.14776), but if I view the same area on the map the change is still not visible (http://www.openstreetmap.org/#map=18/-35.18125/149.14776). I thought the change should show up within a few minutes?

The changeset is here: https://www.openstreetmap.org/changeset/53467064

Hi Nick,
the new way displays just fine now. Usually, a change will be shown on the main map within minutes. Sometimes it takes a bit longer but usually no longer than a few hours. But you should also make sure you do not load the old tile from the cache. Most browsers force a fresh re-load from the servers with Ctrl + F5.

Thanks. I needed the Ctrl+F5 to get the update to show on the map.

I have the same problem, but the solution doesn’t work for me. If I refresh the browser or even use a different browser my newly added track is still not visible on the map even though it displays properly in the editor, and I’ve been waiting well over a week. I’m possibly missing something simple but advice for a very infrequent editor would be much appreciated. This is my changeset: https://www.openstreetmap.org/changeset/53173907

ptpipes: https://www.openstreetmap.org/way/534494022 is visible on the standard, transport, and humanitarian layers. It currently hasn’t rendered on the cycle layer. If you get different results, either your browser or your ISP is caching out of date tiles. (At one time, at least, ISPs tended to assume that images were stable and cached them aggressively, to reduce bandwidth.)

Also, please note that Cape QE alt - v low tide, low swell is incorrectly named. Firstly it contains meta data, as extensively discussed on the map or database thread. Secondly it contains abbreviations, as mentioned in passing on the road naming thread. (The use of abbreviations is probably an attempt to get the name to render in the space available, which is wrong.)

If you want to encode alternatives, it may be better to use route relations. In fact, it is possible that that the name only exists for the route and not for the path, but resolving that needs some local knowledge.

@ptpipes: this path ?

ptpipes: If, as I suspect, this is better considered to be a hiking route, rather than a section of path, you probably want to use https://hiking.waymarkedtrails.org/#?map=11!51.533!-0.1748 to render the map, rather than the standard rendering. This probably will be slow to update.

Thanks for the feedback. I had indeed checked only the cycle map and not the others, and I can see my new walking track is now shown on the cycle map too (although it took over two weeks to appear there). I’ll try to improve the naming and tagging - still very low on a long learning curve.
BTW, these routes are based on my own GPS track, not stolen from other mapping, and while it it true there is no actual “path” along the sandy beach the route absolutely exists where marked. The shoreline is not marked correctly; maybe I should have a go at correcting that.