Ubuntu Tile Server


I am trying to set up a Ubuntu Tile Server with the instructions from the following link http://wiki.openstreetmap.org/wiki/Ubuntu_tile_server
I have tried twice on two different VMs(quad core, 8GB RAM, SSD) Ubuntu 11.04 and 11.10 both 64bit.
Both times I can load the slippymap.html file and I can see the controls but no map, just a white back ground. There is no png files in www/osm/ like they are not getting rendered. I have restarted the server twice and still nothing.

I have the following lines in the Apache error.log file
[Tue Mar 13 00:34:24 2012] [info] [client] tile_storage_hook: handler(tile_serve), uri(/osm/16/34004/22810.png), filename(/var/lib/mod_tile/default/16/0/133/73/209/8.meta), path_info((null)), referer: http://localhost/osm/slippymap.html

[Tue Mar 13 00:34:24 2012] [info] [client] Requesting style(default) z(16) x(34004) y(22810) from renderer with priority 5, referer: http://localhost/osm/slippymap.html

And the following lines in access.log showing the 404 errors when the browser is asking for the png files. - - [13/Mar/2012:00:34:24 -0700] “GET /osm/16/34005/22810.png HTTP/1.1” 404 510 “http://localhost/osm/slippymap.html” “Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Ubuntu/11.04 Chromium/17.0.963.79 Chrome/17.0.963.79 Safari/535.11”

At this point any help or ideas would be great!


Did you check the FAQ there?


Where are the various files (DB / Tiles, etc.) ?

Style sheets and coastlines are in /etc/mapnik-osm-data
Tiles are in /var/lib/mod_tile
Renderd configuration in /etc/renderd.conf
Renderd socket is /var/run/renderd/renderd.sock
mod_tile configuration in /etc/apache2/sites-available/tileserver_site
Scripts are in /usr/bin
DB configuration is in /etc/postgresql/X.X/main
(X.X stands for the PostgreSQL version for example 9.1)
osm2pgsql configuration and state.txt is in /var/lib/mod_tile/.osmosis


Yes I did read through the whole FAQ and checked everything. I did manage to fix the problem my self, so for anyone else out there that has this problem, when you go through the install script you have to hit yes to downloading the coast outlines that are 400Mbs ish, I didnt do it at first because I didnt have the bandwidth, however when I did, everything just worked!