Trouble mimicking downloadable maps

Testing has been on my Garmin Montana 680. Tried following guidelines from to get generic-new style that offered but end up with differences such as buildings not being shown, white backgrounded areas for unmapped terrain become light tan, service roads that were thin dark bordered light roads and unreadable but identifiable blue arrows for oneway roads showing as dashed light+dark lines and no oneway indications, and parking goes from small blue P square to gets the large P with grey circle. Thinking some of that is like there is no typ file expected response but things like no buildings shown is a different issue. Are the github files+instructions supposed to create soemthing so drastically different?
Tried the github openfietsmap full to see if I could get otherwise unoffered maps as never released US maps. I tried to skim for differences vs an official release from which had a large difference even with different symbols if I recall. I think it was steps which I fixed to work with newer mkgmap/splitter/filenames that gave close looking results. Although small, there is a chance I have the two mixed up; not easy to retest without a several hour rebuild per set of steps.
Tried the same github files to try to mimic the openfietslite that site gave out with differences of no buildings, barrier=wall not shown or shown in white; may have been the non-lite showing it in white from my 2nd paragraph testing, but was hard to see it in green compared to the black that it was on the .nl site’s download. Can’t remember if it had green appearance or not. I have not tried to work with elevation/hillshading details again for a while as I found it made the mapbuilding+gps rendering both a lot slower. Thinking I may want to make versions of those map details and POIs all as separate map files if I work out how to have multiple maps of the same area get along to make turning them on/off and maybe selective updates a quicker process.
I haven’t had luck having more than 1 custom made map on the memory card in my GPS; the other map does not list even if the description in the list of maps on the unit appears different and they have different filenames. I was able to have generic + generic new + openfietslite maps from all present for the same area and switch them on/off though sometimes sections of the map were missing which was most common for generic-new. My assumption is this was related to family-id or some similar setting but don’t understand what those settings really mean for the maps to know when they should be the same vs different.
I have my build steps saved on my other computer so everything is quite reproducible. Is this where I should expect to be or do I likely have incorrect steps/files somewhere? If I succeed, would people likely want copies of these maps available or the build sequence itself?

Seems like you have mixed up the OFM lite styles (this map shows almost no buildings) with the Generic New one and/or mixing up the corresponding typ file. Hard to say what went wrong there. Maybe you can try the service where you can request both of the maps (and other styles)?