Three OSM maps loaded on Nüvi, only one visible

I loaded three from OSM derived .imgs, with different file names, on my Nüvi 3490LMT. Basemap shows my Nüvi under “Devices”, but all three OSM maps are called “OSM Street Map” there. Basecamp shows the three OSM maps neatly. So, no problem at all.

But on the Nüvi, if I look on the page “My maps” there is only one OSM map mentioned, called “family name OSM street map”. And only one of the three maps is shown, no trace at all of the other two.

What’s happening here? Thanks.

Maybe the Nuvi got messed up by identical family-ID/name of the three maps. Try the Worldwide map by Lambertus to have a different choice. You dont have to install the whole world, just the area you are interested in.


You can also use MapSetToolKit to edit the FID of different OSM World Map downloads to eliminate conflicts.

Thanks for the reactions.
However, the problem persists.

I make my .imgs using mkgmap. For each map I make I use different settings for the following options in an options.args file:


The gmapsupp.img produced by mkgmap gets a unique name for all three maps I want to put on the Nüvi. Then I copy the three .imgs to my Nüvi. But again, only one map is shown in the Nüvi, no trace of the other two.

On some nüvis, you can store several maps also in a folder called “Map” instead of the “Garmin” folder. Maybe in the Garmin folder only one gmapsupp.img is allowed.
You can also try to make one Garmin folder in the nuvi’s internal memory as well as one Garmin folder on the SD memory, so you can use at least two mapsets. Another trick is to replace the gmapprom.img so you can use three maps this way.

I assume you named also the files differently? Or have you put them in different folders?
What filename /folder has the map you finally see in the Nüvi?


I put the three maps in folder …/maps of the nüvi. Things are improving, because now two maps are visible in the nüvi, but still one is missing. I’ve not the faintest idea why the third map is not shown, I’ve made it with mkgmap exactly the same way I did for the other two.

Do you use unique family-id in the .TYP file as well?

I do not use .typ files (yet).