Tagless points and lines in Greenbelt, MD

I was just looking around Greenbelt, MD and come across a collection of tagless points. They all appear to be from one specific changeset (which I’ve commented on).

There are also tagless lines (e.g. here) which appear to be building outlines but this seems to be related to a different changeset by a different user.

Thought I’d flag here for local mappers to consider fixing.

Well, to understand the reason of unconnected nodes (points) without tag you usually have to take a deeper look at the history. I think in this case the parent way was deleted but not the nodes which leads us directly to the ways (lines) without any tags. Both seem related to Changeset: 134232663 | OpenStreetMap which is a bad, ongoing import. Way: 1158000014 | OpenStreetMap even had a broken shape with several duplicate nodes, fixed in Changeset: 134283422 | OpenStreetMap.
As other changesets of the import (e.g. Changeset: 134783047 | OpenStreetMap) show other problems like adding building=Yes (with a capital Y in the value) and addr:city=UPPER MARLBORO (the whole value in capitals), e.g. Way: 1161399038 | OpenStreetMap, it would be best to ask the author of the import to rework her/his workflow and to use some proper QA tool like JOSM validator before uploading.


I have just commented on both changesets and asked about a review of all the changes of the last weeks and a review of the workflow.

No response to my comments and the badly designed import continues. Mean while, I wrote a PM in addition:

Hallo, would you please respond to changeset comments, OpenStreetMap (OSM) Changeset Discussions, and stop your badly designed import plus review all your changes of the last five weeks and fix the errors.

Your workflow and “ArcGIS Editor for OpenStreetMap” do not seem to work properly. Please, update your workflow and use a better editor software, like JOSM, to get warnings about unconnected nodes, duplicated way nodes, way contains segment twice, self crossing ways, self-intersecting ways and incorrect values of tags. Additionally many buildings should be simplified by removing useless nodes. Last but not least, please make sure your source is up-to-date as available aerial imagery sometimes show different results.

Thanks a lot and all the best,

As I won’t have much time the next days and as I am tired to discuss with paid mappers doing a poor job, maybe, some one else can take over.

Bit of a long shot, but have you tried actually emailing them using the email address that is listed in their OSM profile description?

Following a different request to the DWG, I’ve added https://www.openstreetmap.org/user_blocks/7057 and asked the recent importer here to join the conversation.

I’ve not looked in detail at the “tagless points” from four years ago mentioned at the top of the thread yet.

– Andy (from the DWG)

1 Like


I have viewed the messages/comments and appreciate the input. I am addressing the issues with the ArcGIS Editor workflow and rethinking our upload process. Any tips for updating such a large area are greatly appreciate. To address the aerials, the aerials that are being used should be more up to date than Bing.

Thank you and I look forward to any tips for better data!


Note that you need to follow Import/Guidelines - OpenStreetMap Wiki

If you have followed it then I would encourage to link import documentation page here in this thread and in any future changeset (in changeset tags or edit description)


The “tagless points” are definitely a result of the mentioned changeset.

@M-NCPPC_Import I can see ongoing fix-up activity at https://www.openstreetmap.org/user/M-NCPPC_Import/history but I don’t yet see anything at https://wiki.openstreetmap.org/wiki/Import/Catalogue. Have I missed it and was an entry already there?

For the avoidance of doubt, you do need to follow https://wiki.openstreetmap.org/wiki/Import/Guidelines and (assuming that steps 1 and 2 have already been followed) step 3 says " 1. You must register your permissions and project by adding a line to the table at Import/Catalogue.".

1 Like

Regarding the workflow, there are already many imports of buildings documented, see Import/Catalogue - OpenStreetMap Wiki, e.g. Baltimore Buildings Import 2.0 - OpenStreetMap Wiki or Hamilton County Building Import - OpenStreetMap Wiki. The actual steps depend on your original source.

For the manual parts like deleting or replacing, I highly suggest to use JOSM as the utilsplugin2 ships the action “Replace Geometry” which is also used by the conflation plugin. Additionally, JOSM Validator is a good QA tool and it can be quite easily extended by custom rules.

Indeed, but we really need to get the first parts of the import guidelines sorted out before we start thinking about fixing the data, What even is the licence? I notice that @M-NCPPC_Import has been active in the last 15 minutes but still hasn’t replied here or updated the import catalogue.

If communication doesn’t occur any other way I’ll have to don a DWG hat again and ask them to contact us by email (and block the account until they do). That’d be a pain because it’d prevent them posting here until the block is lifted (and obviously we want them to post here first!).

Edit: See https://www.openstreetmap.org/user_blocks/7067. Hopefully that’ll just be for a few minutes until we get the email.

Edit2: Now revoked

Unfortunately M-NCPPC Planning Department - OpenStreetMap Wiki seems to work as both, the project page and the import description. There is a line in the table at Import/Catalogue but its status is still “planned”. Looking at other lines of the table updating seems to be a common problem and not tied to this import.

Alas https://wiki.openstreetmap.org/wiki/M-NCPPC_Planning_Department was last updated in 2019, which isn’t great. Also https://wiki.openstreetmap.org/wiki/M-NCPPC_Planning_Department#License says “https://creativecommons.org/licenses/by/4.0/” which isn’t compatible


I attempted to create an account to update the Import Catalogue, but I could not due to some IP address issue.

If I can do so, I will, but I was unable to. I have gone back and cleaned my previous uploads with JSOM validator.

Thanks! If you can provide a few more details about the actual error I’m sure that someone would be able to help.

I tried turning off VPN, that didn’t help.

For info, https://help.openstreetmap.org/questions/18937/what-dnsbl-used-for-the-wiki has some info. No idea if the two providers listed there from 2013 are still valid.

If you have the ability to sign up via a different route (perhaps, tethering to a mobile phone) then you could perhaps try that.

Mobile phone worked. I am updating Import catalogue.