STUCK on the state of the map picture!

Hello, I had a very basic use of Openstreemap on my androïd phone, it worked fine (thanks).
A few weeks ago, I got a “state of the map” picture (instead of my map) that prevents me from using Openstreetmap since:

  • I cannot close the picture (clicking for closing does not work) and get rid of it.
  • I cannot find my map back.
  • I can access to the search function but searching for a place (map) does not work (the searching is launched but does not supply results)!
    Same thing with another browser - I haven’t change their settings!
    What is this spell?
    Can you help?

The “x” to close the banner ad is often difficult to see. Most of us will be logged into OSM & therefore wont see the banner. I’ll have a look to see if I have the same problem.

Thanks SK53 for your answer.
I clicked on the “x” to close the banner, I could see that my clicking was taken by the software but nothing happened (no closing of the banner).

It works for me as well, so I’d suggest reporting it as a bug. You’ll need to provide details of which browser(s) on which platform(s) you have tried.

Thanks. Wileyfox Swift, Androïd 7.1.1, with browsers :

  • Firefox Klar, 6.1.1
  • Firefox 50.1.0

Hello any feedback - have you got enough information? I am not sure what you mean by platform but using no platform but from my browser (got from F-Droid)

I don’t think this forum is the right place to report a bug with, although I must admit I don’t know where you should go.

The general place to report issues with the website is .

I’ve no idea what “Firefox Klar” is, but Firefox 50.1.0 is really, really old. The current version I’m using on Android is 103. If you update to a modern browser, do you get the same problem?

At this page Mozilla say that your version isn’t supported any more and that modern versions of Firefox are supported on Android 5 and above (which is a pretty low bar).

Thanks to SomeoneElse for feedback. About browsers, I use only the F-Droid store, this is my problem yet (I wish I have soon a new degoogled phone with more apps available). FYI I will not go further about this bug.

may be what you want.

Thanks SomeoneElse. FYI Fennec app on F-Droid is not available for downloading on my phone.

Have a look at Organic Maps.
Is has several adventages against using openstreetmap’s site in a browser, like offline use, bookmarks. etc.

BTW, is your f-droid app up to date?

Thanks for advice Muralito,
Yes, my F-Droïd app seems up to date.
Actually I don’t understand why I cannot install OrganicMaps app on my phone neither.

Thanks for your help. Actually, I guess that these problems come from my old android (7.1.1) with my old smartphone… :frowning: