Spoken Street Names on Nuvi 5000

I have been using the default style for mkgmap, which adds the road number to the street name for the displayed highway name. However when Emily say “Turn left onto the …” only the road number is spoken. e.g placing a way point on a street will show as B5125 High Street, but Emily just says Turn left onto the B5125. Emily is set to read street names in the Garmin settings. Any suggestions?

Solved by adjusting the line style to

Set highway names to include the reference if there is one

highway=motorway {name ‘${ref|highway-symbol:hbox} ${name}’ | ‘${ref|highway-symbol:hbox}’ | ‘${name}’ }
highway=trunk {name ‘${ref|highway-symbol:hbox} ${name}’ | ‘${ref|highway-symbol:hbox}’ | ‘${name}’ }

highway=primary {name ‘${ref|highway-symbol:box} ${name}’ | ‘${ref|highway-symbol:box}’ | ‘${name}’ }

highway=secondary {name ‘${ref|highway-symbol:oval} ${name}’ | ‘${ref|highway-symbol:oval}’ | ‘${name}’ }

highway=* {name ‘${name}’ | ‘${ref}’}