Splitter (MKGMAP) not working in Windows 8 (With Java 7)

After a long struggle to get Java 7(JRE) running on a 64Bits Windows 8 system, It seems Splitter is not working ???

The cmd dialog box is only to see for a short time, how can a pause that one?

How to list a help screen for Splitter…

Any help is much appriciated… Windows 8 is driving me nuts :confused:



Hi Bert,
The command for the help options (with output to a txt file)

java -jar splitter.jar --help=options >options_splitter.txt

I dont have win8 but it shouldnt be a problem to run it.

The command line could look as follows:

java -Xmx2000m -jar splitter.jar --output-dir=splitter --mapid=10010001 --polygon-file=%DIR%\resources\benelux.poly --max-nodes=1750000 --write-kml=benelux.kml --output=o5m --geonames-file=cities5000.txt --description=OFM_BNL %DIR%\Splitter\benelux.o5m

Gives me a empty file…

I see that there are errors, but how to see what the errors are … the dialog is to quick.

All the files worked with my old Vista computer, which died recently :open_mouth:

You mean you are starting the programm “cmd.exe”, type in your splitter command, and then “cmd.exe” crashes? I don’t have a Windows 8, but: Even if splitter crashes, nothing happens to any command line interface - so that should be readable.

No, I see an error dialog for about 0.5 seconds but it is to quick to read, but I can see some class.xxx and method in it… only wish I can freeze it to read proper.


why dont you make a batch file?
Put the command string in a text file, and on the second line
Save it as splitter.bat and run it.

I think you need to run the splitter in its own directory, it needs other files, you cant run a standalone splitter.jar, so

same result

Well, then you could post your question on the mkgmap mailing list…

Maybe this helps?


  1. Fix for java.lang.NoClassDefFoundError in windows:-

To solve NoClassDefFoundError error in windows , we have to set CLASSPATH environment variable.

to set classpath in windows, we have to configure the below values


%CLASSPATH% means existing classpath to be added and . points to current directory

Downgraded to Java 6 update 43 → Everything works OK
Update to Java 7 update 25 → Nothing works and the computer is getting slooooooooooooowwwwww

So for now I will stick to Java 6 and hope this get solved in another update :frowning:

It seems that depending libraries are not found. They are contained in the splitter-r305.zip file.
Please ensure that your c:\test directory contains the complete contents of the downloaded splitter-r305.zip file. At least the lib directory must be in c:\test