South West Spain not showing

Hi. I want a map of west of Almeria to the border with Portugal.

I’ve tried to d/l it several times and I get a solid land mass west of Almeria, showing Morocco joined to Spain and no Mediterranean. Also, there is no Atlantic, just a huge land mass.

Any ideas from anyone as to what’s wrong? I’ve done a full Spain and also done it as selected tiles - same result, just a land mass and no coast.


WHICH map are you using?
WHICH device? PC? Phone? Android?


no problems:

The normal openstreetmaps one rhat generates the image file to put on a SD card. I’m putting it on a card that’s going into my Garnin 76CsX, same as I’ve done for years. As I said, shows a part of Spain but not the bit I’m currently in. I suspect it’s something dumb I’m doing.

We now know you are using a Garnin 76CsX but …
Do you use any of these
or do you use these to create your own maps from OSM data

It is likely that you use
I would try one of the ready made maps for the Garmin from a different provider and replace the map you have got and see if the problem is still there. I wonder if the map had been made with an incorrectly set option, such as the sea, coastline options or other corruption in the map making process. See the mkgmap options here

I don’t know if it would have an effect on what you are seeing, but you could try with and without the garmin basemap enabled - gmapbmap.img
It may assist in rendering the coast.

Edit: Hoges was able to get the Spain map to display correctly after disableing the garmin basemap