Some roads not rendering with

Hi All
I’ve looked through the forums and can see some threads with similar problems, just not quite the same (I think). My tiles look good apart from most roads not rendering. I’ve linked to a couple of examples:

Not sure what info is relevant to include to help diagnose the problem, please advise

I’ve read this post: and my problem is the same. I originally downloaded the file (size 121M) and then tried with (size 160M). I was hopeful this would work but it didn’t. I dont really want to download the entire planet.osm unless i’m sure both of the extracts are wrong. Any suggestions?

i have had the same problem a few days ago. I downloaded germany.osm.bz2 from and got the same result as in the pictures above. I used the package version of Ubuntu 9.04 and I think one of the tools had a bug. I then switched to the svn version of osm2pgsql, mapnik and the mapnik-renderer and now it’s all working with the same osm-file. Try out the svn-version - with Ubuntu it isn’t hard to compile.
Greetings from Germany!


Thats it. Nice one Taraquedo! It was osm2pgsql that changed things for me. Now rendering zoom levels 12-18.:cool: