Some buildings aren't visible on map

I’ve added some administrative and government office on map. But I can’t see them on OSM. Whats the problem? I’ve tried both id editor and JOSM. Tags: office:government, office:administrative. Help!

Are you saying that they are not rendering in one of the rendered forms of the map, or that they are not being entered in the map database.

If the former, the rendered forms are aids to mappers, they are not required to display all the information in the underlying database. All the same it would help if you could identify the specific objects concerned.

However, you should note that offices are not buildings. If the office is also the whole of a building, you must include a building tag, as well, otherwise, at most, only the name will be displayed. There are various possible strategies if the office is only part of the building, but they will generally involve mapping the building independent of what it contains.

As most, or all, of your changesets have source=local_knowledge, I wouldn’t expect to see any building outlines, as they generally require surveying or tracing from aerial photographs.

I cannot think of any way in which an object would selectively fail to be added to the database, without some sort of error message at the time.

One other thing, could you please make sure that all your changesets have changeset comments, and that they say what that specific changeset is doing, not just that you are mapping in the area. That might have allowed me to find the offices to which you are referring, and it also makes it easier to audit changes.

As hadw pointed out, not all things get rendered on the standard map. I believe nothing with the office tags gets rendered at the moment, even not when there is a name tag.
Take a look at and add the most appropriate building= to the outline of the building.

They are in map database and I can see them in edit mode. But I can’t see their name/icon on general map(standard layer) at any zoom level. I’ve tried id(in browser) editor and when I add any such building they contain only 1 tag like office=government or office=administrative So, at first I didn’t add the building=* tag. I’ve then added building=office tag but still I can’t see the name/icon in map.

there is no icon for an office on the standard map. It is also possible that even the name is not rendered. The edit mode shows much more details than the rendered map. That is normal.
I’m currently mapping lanes and turn:lanes, they are not visible on any the maps that I know (many more than the 5 on, but they are useful for navigation. I’ve learned not to be bothered that there is no map showing this or that information. So don’t worry that there is currently no map showing the office-data and keep adding this useful information.

But they are important. 2 of them are something like city government office and 1 does all administrative works of the city. In our country every city has 1 of this office. Is there any other way to make them shown to map?

When you tag the building outline with building=yes, they will show up on the map.
If you want offices to be rendered on the map, you have to create an issue on the github site for the mapnik renderer. I don’t have the link for that.
You could search this site, or for the link.
Please do not tag them in a different way just to show them on the standard map, this is called “tagging for the renderer” and nobody likes that.

While I understand that you find this an important object to be rendered, everybody has his own idea of what is important, depending on their background and usage of the map. It’ is impossible to make 1 map that fulfils all this conditions. E.g. waste bins are also not rendered, but they are important when walking a dog :slight_smile:

You should treat the map on as a sample of what is in the database, not as the ultimate map that shows everything what is in the database