[SOLVED] Street name change depends on zoom, why?

The street that I used to live is called Rugat in Valencia, yesterday try to search for it in OSM, couldn’t find it, at the end found out that the name was wrong, changed it, and now when I tried to search again, it did not come up with new (Rugat) nor old (Rugatt), the weird thing is if you zoom out at maximum, it showed Rugat, if you zoom in a couple of times, then it showed Rugatt, the old way, why? How can I fix this? Please see the screenshot that I took (the street is almost at the center of the screen).
ps: how do I upload an image from my pc?

You have to wait a couple of days, osm is very slow the last weeks (in Valencia)

OK, thanks for this tip.

You can always link to a street in osm https://www.openstreetmap.org/way/23290337
Click on the “?” first and than on the node or street.

Sorry for this dumb question, but in your url, the “?” is located at the right side, the last icon with an arrow+“?”? If not, where it’s located?

On the right side of your screen, the black button “arrow with the ?”

You can also clear cache in your browser. Try to use Ctrl+F5 or Ctrl+R on map view to refresh tiles on your computer.

Not helping here, I still waiting for changes I made one weeks ago :frowning:

Thanks. got it.

I can see name of this street as

Carrer de Rugat

(with single ‘t’) at all zoom on my PC, so if you don’t see changed street name it has to be problem with your cache. You made change this name two days ago.

DeepHistory of this way: https://osmlab.github.io/osm-deep-history/#/way/23290337

The weird part is if I zoom all the way in, the name has only one t, but zooming out a couple of times, it showed tt, is this a cache problem? How can I attache images?

Here in Spain on zoom level 16 it is still with double tt on different browsers.
Maybe not all the osm servers give the same result?

Maybe you are right, it could depend of server - my browser shows me this street in this way: https://imgur.com/a/qic8UEc

Attaching image is possible only withe external services i.e. imgur.

Zoom 19:

Zoom 18:

Zoom 17:

Zoom 16:

The worst of all is I’m afraid I messed up good this time, before my change, if I searched Rugatt, it’ll show, after the change, it won’t show any of Rugat or Rugatt, maybe it’s a bug?

Search on “carrer de rugat” https://www.openstreetmap.org/search?query=Carrer%20de%20Rugat#map=19/39.46923/-0.35252

I can find ‘Carrer de Rugat in Valencia’ (look at image below) - first result in list is the house with number #1, but under ‘More results’ button OSM shows me the street also (second result).

Remeber that, if you are editing streetname, than you should also edit addr:street tag in POI’s. The easiest way to do this is with JOSM, where you can search similar tags in nearest objects (under right mouse button).

Thanks for this tip, today I can do a search, no idea what happened, it’s good to know that the correct way to change is through JOSM (BTW, is there any tutorial on how to use it? I’m a newbie, just started with OSM). As for the change, I followed a post which said to use the Edit button at the left top of the screen, and that’s what I’ll try to learn JOSM and use it to change next time.

You can start here for josm https://learnosm.org/en/josm/start-josm/
Searching for “josm tutorial” gives also a lot of results in Google

Thanks so much for your tip, I’ll start to learn it.

Yes, there are many tile caching servers: https://hardware.openstreetmap.org/#tile-caches

You don’t need JOSM. iD is sufficient for 99% edits.