Solved JOSM uploading delete with visible=false

Hi all

Recently we encountered a changeset in which a JOSM upload resulted in apparently deleted relations.
E.g. the red elements in the south of the area in question, rendered in

Looking closer, it is becomes obvious that rev 1 of all the “red” highlighted elements in question is still valid and in place, as rev 2 with its delete was uploaded with “visible=false”.

Does anyone know when or how these happen? Just an JOSM>API glitch in which somehow a double delete/undelete action is included in the same API request? (somehow similar to the good old “manual undelete”)


Edit: I should add that no delete was intended by the editor uploading the CS with rev2.

Not sure if I understand the problem. All deleted objects have the visible=false flag.
An unintented delete can happen when you e.g. search for building=yes and press Del.

Or only a bug in Overpass with the following issue still open?

Sorry added the information on the delete not being intended only in a edit.

Please explain what you mean with “elements in question is still valid and in place”. The database says that way was deleted, so I assume you want to express that the mapper did not intent to remove the way. It is VERY unlikely that JOSM sends a delete to the api without telling the user that this will happen, so I assume the mapper simply did not double check the list of changes before uploading.
The next thing to do is to revert eihter the full changeset or only a part.

OSM never remove objects from the database. Deleting an object in OSM means basicaly changing the tag “visible” to false so it won’t show up in the map and won’t be transmitted if you download data from the database.


All correct, it was my (rather stupid) fault. iD somehow managed to submit a changeset twice and thus created duplicate entries. Obviously a later JOSM edit in the same area filtered the duplicates. Only now noticed there existed 2 identical entries at some point. Will refrain from using iD on bad network link, promised.


Please add Solved to the title (edit the first post)