Routable Garmin maps:

another question too at what stage can we either get access to the tool or will you be updating the maps currently on your site, I guess Monthly update would be ok or if you want to distribute the load by region I assume other people would be happy to help.
btw thats great news on that device compatibility.

Hello - I’ve tried to download the Europe routable map, as well as some individual countries. Unfortunately I’ve run into problems:

  • The Europe and Germany .img zip files seem to be corrupted and I can’t unzip them.
  • I can search for POI, Lodgings, Attractions, Cities, but I cannot search for Addresses - any input in the ‘Addresses’ fields returns ‘no results’. I was trying this with the Italy map (combined with Austria, Switzerland, & Czech Rep.)

This is on a Garmin eTrex Vista HCx.

Looks like the maps have been updated, thanks

just wondering if the Suburbs can be added to the “City” name search in Mapsource

eg in City navigator I can search for “Rivett” (suburb) but the OSM versions doesn’t show Rivett in this search

Hi Radomir,

I notie that the new Australian maps don’t yet recognise roundabouts. Is there a plan to do so. (Canberra has more roundabouts on it’s roads than kangaroos, and that’s saying something.)

I’ve just loaded the the new October 14th Maps, but the roundabouts still don’t work. Is this because, down here the roundabouts go clockwise?


I’ve installed the UK-Ireland maps using the Mapsource Installer version dated 2008-09-24.

However, when I try to send these maps to my device I get the following error during the building index phase:


I’m using Mapsource 6.14.1.

Is this a known problem for 6.14.1 and the Routable Garmin maps?

Did you see the stickied post on the top of this subforum?

Doh! I’ll try that MapSource Maps Compatibility tool and see if it fixes the problem.

I presumed I didn’t need that as the routable maps are viewable, searchable and I can create routes using Mapsource.

I get the same problem when I used the 6.13.7 binary

Oh, ok, then it’s something else… no ideas though :slight_smile:

I’ve had the maps on my GPS for a few weeks now, testing them with routing every now and then. It seems weird stuff is happening when roads cross highways (I guess: in general 2 roads crossing each other) without an intersection or connection.
As an example, take the situation near N51 33.217 E5 28.662 (let’s call that X).

I’ve created 2 waypoints: N51 30.823 E5 27.317 and N51 33.440 E5 28.226, and created a route between them. For some weird reason the road first takes the A50, turns at the first crossing after X, goes back at the other side of the A50, and then goes to the Nijnselseweg, which is actually on a bridge over the A50. I’ve checked the OSM data, but it is not a mistake in the data as far as I can see.

I’ve seen this in a few more places by the way, this is not a single weird place.

Hi, I have been trying to create a Routable map for my Garmin Nuvi 300. I have read this post. The map I am trying to do is for Malta, Europe. I know it doesn’t have much information but working on it!! Malta has lots and lots of roundabouts. I created a non routable map. Can some help me how to do it. I used mkgmap to convert the osm into img “java -jar mkgmap.jar data.osm” than I opened the img with mapedit I clicked on Generate Routing Graph > using considing Node of polylines. I saved the map as *mp.
Than file export > Garmin > Save. The Exporter request cGPSMapper. Then error:
Importing and preprocessing data

C:\media\Data\osm2vgps\ : Warning W014: RGNLIMIT should not be lower than 500.
Current import datum is: W84 :WGS 84 Global Definition II
Reading [ZIPCODES]
C:\media\Data\osm2vgps\ : Error E019: Street cannot intersect with itself! Split this element!

Verify Map also has error. can some one try the make this map routable and give me how to do it.

Ok I have done it finnaly.

What I done.

Tools I had:

  1. I got the are that I wished to get and saved it using JOSM in osm format in the “osm2mp” folder
  2. in terminal i typed
perl default.osm >
  1. i copied the in the mkgmap folder
java -jar mkgmap.jar --route --gmapsupp

2 files were created one with 8 digit and the other named “gmapsupp.img”

Insted of step 1 you can export the are from the openstreetmap site

good news thanks, I was wondering if you could add the to the OSM Wiki somewhere so other people can find your instructions…

The next step is to create a mapsource compatible install procedure, so people can browse and combine OSM maps with others eg topos etc…

which version of mkgmap is that? mkgmap website on the download page has lots of releases
mkgmap-latest.tar.gz, mkgmap-r830.tar.gz, etc. And at I see another version Has the routing capability been merged into the latest releases?


I would like add installers for routable maps on my site, but I wonder how routing is supposed to work across multiple tiles. Obviously you cannot create a single tile for any whole country (A small country like the Netherlands alone needs about 200 tiles already). Therefore any routing capability is worthless if you cannot route across multiple tiles. So the question is, does that work?

Thanks liosha.

Here’s an example of connecting nodes between tiles to make it routable

Tile 1
Label=~[0x04]E2 NSE
Data0=(3.0391936,101.7062182), … (2.6274582,102)


Tile 2
Label=~[0x04]E2 NSE
Data0=(2.6274582,102), … (2.1308003,102.7412188)


The third value of Nodn of the connecting nodes has a value of 1. In Gpsmapedit the connecting nodes “Is external node” is set to true. I’m not sure how you guys can implement this as there’s a need to read all tiles to match up the connecting nodes.

To whom it may concern…
I had problems with getting Mkgmap started in XP.
Saw in German forum that I had to put the Mkgmap.jar program in de directory C:\Program files\mkgmap… I did so and did also put the downloaded osm map in the same directory.
Then I went (via accessories -command prompt to the old black DOS screen.
There I changed in DOS mode the directory to
C:\program files\mkgmap
After that I entered the format to start mkgmap.
C:\program files\mkgmap java -jar mkgmap.jar mapcur.osm
Where mapcur.osm is the osm map I renamed after downloading.
It so happened that in de mkgmap directory the file 6324001.img appears…!
So obviously it worked so far… will now see how it shows on my Garmin.


there are red squares on which means these maps are not available. I’m driving to Denmark in 3 weeks, where can I get the red labed squares - especially 63240180.img.