reykjavik is under water

I used the iceland map due to the small size to test the behaviour, which I observed in other, bigger maps also.
When I download from the internet (raumbezug) a map of iceland and show this map with garmin basecamp, the coastline shown is different from the real coastline. The result is, that parts of the land seem to be under water.
I tried it now myself, installed the newest version of mkgmap, downloaded from “Geofabrik” the iceland.osm and executed:
java -jar mkgmap.jar iceland.osm
The result is the same: Parts of the land areas seem to be under water.
Obviously I should use some options of mkgmap, but as a beginner I dont know how and which one.
Any help?

did you use the option --generate-sea=extend-sea-sectors ?


Thanks Cris. I tried it now, but this does not change the behaviour. Another observation: If in basecamp viewing the iceland map I press Ctrl G (=basic map only) this shows a basic map with the wrong coast line.

Which map did you download? If you downloaded or compiled a gmapsupp version and showed it in Basecamp, you will see the (very rough) basemap shining through the OSM map. Thats why it is likely that you saw water on the map, because the gmapsupp’s are (still) transparent and the basemap is not very detailed. With a experimental version of mkgmap this problem is solved. Try to compile your map with mkgmap-gmap-mdr-r2144.jar from (this jar file must be put in the existing mkgmap directory if you use the iceland.osm.pbf).
Another option is to install the nsis version.

Hmm is this the same problem as you already asked in another topic: ?

Thank you , ligfietser, especially for your patience.
"Hmm is this the same problem as you already asked in another topic: " In principle yes. But I misunderstood your last entrance under this topic (“The bug of Basecamps Base map superposes the OSM map has just been traced and solved by developer Steve from mkgmap, so sooner or later the results will be visible in all the OSM maps that are produced with mkgmap.”) and thought, in the newest version of mkgmap this problem would be solved now. And the downloads from raumbezug are produced under a former version of mkgmap. So I tried to produce a map myself with the result as reported here.
But you reminded me now to your advice with the empty basemap. I forgot this and lost the old settings because I switched from basecamp to basecamp 33 beta which is installed in other folders.
As I said already in the other entrance, I am a beginner in this area. I decided now to be a little more patient and to by now first a book to learn how Java works (I made my first programming exercises on a ZUSE Z22 and Java was only an island at that time).

The latest versions of mkgmap still contain this bug, but in the experimental mkgmap-gmap-mdr-r2144 jar file this one is solved. Just copy it to the folder where you have your regular mkgmap version and run java with mkgmap-gmap-mdr-r2144.jar instead of mkgmap.jar The result is probably that you dont see the basemap through the osm map anymore.