Rendering tiles with Mapnik on Windows

Good afternoon,

A few years ago, I had a full set of tiles on Windows, created with osm2pgsql and mapnik

It took me a while to get this working, but I did.

Unfortunately, I had a disk controller die and I lost it, though recovered some… and then a colleague deleted the disk I recovered.

I am trying to recreate the maps, but struggling with finding the instructions I had before. I have my parameters that worked before, but I can’t find the installation or even the installation instructions I had before.

I have imported all the data for my region into PostgreSQL. Had some minor struggle, but all done now.

The import took just over 9 hours for the UK and Ireland. (When I tried to edit the .conf file to improve, then I could not start the postgresql service, so had to leave it at defaults.)

I am now looking to render the tiles. I seem to remember before downloading a Mapnik for Windows, as an exe, however, when I go to the downloads on mapnik website, it is a zip of the source code.

Am I missing something? (well, obviously I am, but I am struggling to find any direction). I need to know what I need to install and where to get it from…

Thanks for your help.

For anyone else struggling with getting Mapnik running with, this is what I had running before and my tiles were created. osm.xml output_osm.xml --host localhost
–user postgres --dbname osm --symbols symbols/ --world_boundaries world_boundar
ies/ --port 5432 --prefix osm --password put_your_password_here

This may be not directly relevant to what you’re trying to do, but if anyone absolutely must generate raster tiles like this on Windows be far the easiest route is still likely to be via WSL. I tried this a while ago (with WSL 1 rather than WSL 2) and it basically “just worked”.

I haven’t tried on WSL 2 or more recent switch2osm guides (mod_tile changed fairly significantly in the Ubuntu 22.04 release) but I’d be surprised if there is an insurmountable issue.