Rendering Arrows of street directions TYP file

Does any one know how to build a TYP file so as to see the arrows on the map?
It would be very useful to check and correct street directions if we could see the arrows on the GPS screen

You can find it here:

You may also like to look at new type editor , Typ Wiz, designed to create and personalise typ files ‘in a flash’.

The pages explain every thing very good, but I failed over and over

The typ wizard seems not to work on my W7
MSINET.OCX or one of its dependencies not correctly registered
Any clue on this?

liegfietser (strange nick, what does it mean?)
cferrero has very good explanations which help me to make every thing for compiling with mkgmap
All seems to work until I have a look to the map on my GPS and nothing has changed

compilation with mkgmap works, I can change family-name, description

family-id set to the same value of TYP file

All styles file under the same directory mkgmap-r1625/resources/styles/Beerforfree
info (modified)
lines (modified)
overlays (new)

My config.args file:


My batch file:

java -jar mkgmap.jar -c config.args 63240932.img 63240944.img 63240980.img M0000578.TYP

My overlays file:
0x121: 0x01, 0x10
0x122: 0x02, 0x10
0x123: 0x03, 0x10
0x124: 0x04, 0x10
0x125: 0x05, 0x10
0x126: 0x06, 0x10
0x127: 0x07, 0x10

The typ file M0000578.TYP
is a copy of the CF1400.TYP on the page then removed everything but the line with the arrows

Anyway thanks for you help and willing

Beerforfree, it should work now - have made a slight alteration - you may not have msinet.ocx on your pc.

It works on Mapsource but not on your GPS

Have you checked to see if the FID of the TYP file matches the FID of your img?
If they don’t, the typ file won’t work on your GPS.
You say you’ve copied Charlies TYP - more than likely it’s not the same number.
I use MapsetToolkit and it warns you when it meets a conflict.

One more thing you have to notice.
Some gps untis don’t display two types on top of each other, like the nuvi.
So in order to see the arrows, you will need to make a wider bitmap and put the arrows not in the middle but on top.
In my line style I dont need to use the layer style, I just put this code at the beginning:
(oneway=yes | oneway=1 | oneway=true) [0x10007 resolution 24 continue with_actions]
For this Garmin type 0x100/07 I made the following typ:

btw ligfietser = recumbent bike rider :wink:

I think the problem is somewhere else,
I made some additional changes on the line style file like changing all highway_links to be rendered the same as the highways. E.g. primary and primary_link to have the same representation and this isn’t working as well
I removed the typ file from the compilation, no changes
I removed the overlays file from the directory and the typ file from the compilation, no changes
I replaced the linux slashes"/" by windows ones "", no changes
It looks like the styles I wrote aren’t being read by mkgmap despite my Nüvi 205w won’t show types on top of each other

the gmapsupp.img family-id is changed during compilation with mkgmap using the option --family-id=XXXX

Will try something later

Ive read this before on the forum. Maybe mkgmap doesnt see your style file
when your style file is in the resources folder of mkgmap?
Try to put it somewhere else, like


Did not worked too changing the directory but I will keep trying. I will come back with someting, hopefuly the solution ha ha ha