Problems with updating and downloading of maps


I hope this is the right forum for my question.

I use Osmand from F-droid.

In December 2019 I downloaded all state maps from Germany, that worked fine.

If I click on Download maps, Osmand starts “Downloading list of available regions” but quits that process without downloading/showing anything.
“All downloads” is empty except for voice prompts.

“Updates” is empty as well, at the bottom is a message “Downloads not found, please check your connection to the internet”.

I have just updated to 3.7.4 with no changes.

I allowed wlan and mobile data for Osmand, as well as back round data and the rest. I use my mobile internet connection.

I have no firewall installed.

I have a Galaxy S5 with LineageOS 16.

Does anyone has an Idea what the mistake is and what I can do? Thanks!

Alright just deleted and reinstalled the app, now it works. I didn’t want to do this because i thought I might loose the downloaded maps. I made an Backup, but that wasn’t even necessary.

i have the same problem, i’ll stay here and wait for the solve)):rolleyes: