problems with osm2pgsql import. data is missing

I have question with regard to osm2pgsql. I have imported a planetfile with the following styleFile and there is supposed to be polygon with the name ‘Berliner Fernsehturm’ and osm_id= 19046101 and this polygon is not included.
The way has the tag tourism=attraction, thats why I thought that the way should be in the database. Do I need some more tags in the StyleFile? Whats wrong with it?

thanks in advance

Here it is:
#OsmType Tag Datatype Flags
node,way name text linear
node,way leisure text polygon
node,way tourism text polygon
node,way shop text polygon
node,way natural text polygon
node,way historic text polygon
node,way man_made text polygon
node,way sport text polygon
node,way amenity text polygon
node,way barrier text linear
node,way highway text linear
node,way atm text linear
node,way shelter text polygon
node,way tunnel text linear

node,way wikipedia text polygon
node,way wikipedia:de text polygon
node,way wikipedia:en text polygon
node,way wikipedia:fr text polygon

I imported the planetfile of Berlin again, but this time with the from /usr/share/osm2pgsql.
When I count the entries in planet_osm_polygon I get just 13 rows.

the problem seems to be somewhere else.

Any ideas?

no ideas?

maybe the dumps of geofabrik are broken? could somebody try to import the Berlin-File. This would ensure that the problem comes not from osm2pgsql.



I’ve found out that the dump is ok and that is has nothing to do with the style file.
when I run osm2pgsql with the -E parameter and 4326 as value I get 13rows in the planet_osm_polygon table and when I run osm2pgsql without the -E parameter i have over 13000 rows.

What has the E to do with the amount of rows?