problems opening josm jar file

I am on Mac Os 10.4 (which should have Java 1.5 already installed) but if I double-click on the josm.jar file ( got josm 10.5, 10.10 and latest built, all the same), it is not opening or installing anything. If I open it in Stuffit, I am getting a numberf of files, but no program. What am I doing wrong?
I was just at the OSM meeting in Berlin, but nobody sis using MAC over there.
Please help,
Best wishes,

Try one from before the summer look in the dl dir. And if it that works then email Frederik Ramm or enter a bug report on the openstreetmap bug tracker

(EDIT: I forgot to tell you what to open it with… :slight_smile:
Are you opening it with Java? Try ctrl-clicking or right clicking and then choose open with JAVA. It worked fine for me last time.

JAR-Files are ZIP-Files containing Java-Code and other files needed to run the program. Somehow your MacOS assumes that JAR-Files are archives and not executables (like some of my Windows-Systems…).

On Windows I created a shortcut on the desktop starting JOSM as paramter for the Java-Executable:
“C:\Program Files\Java\jre1.6.0_03\bin\javaw.exe” -jar “C:\Program Files\JOSM\josm-latest.jar”

There should be some equivalent under MacOS…

Yes you choose the file, then press Apple-I (or info from the File menu), then go down to “open with” and choose Java…

Thanks for all the answers. Here is my confusion: I do not find an application “Java” only Java plugins and other Java parts. Where do I find Java if I want to use open with?
Also: The josm.jar file indicates “Jar Launcher Dokument” in Finder, thus it does seem to look for the right software to open it. (?)

I did run the software-update from the main menu (Finder), which was running without errors. However, I also tried to download and run the new Java1.5 update from the MAC website, here, I am getting an error: it tells me I should first run the previous updates for 1.3 and 1.4, which i already did.
Maybe, do I have to go to a MAC forum for that problem?

Thanks again for help

Okay, got it! I had to download a multitude of Java updates, one after the other, especially a J2SE-something update, which I had not recognized as Java related.
JOSM launched! Eureka!
Thanks again, your answers somehow put me on the right track!
(BTW, there is no “Java” you can launch or target by using the open file dialog!)

phew, such a bugger, that you need at least one machine with the newest full upgrade to launch applications made by those linux guys!!!

Thanks again, best wishes

True it’s called “Jar Launcher” not Java, to easy to associate.