Problem with --remove-short-arcs in mkgmap

I’m running mkgmap r1894, and if I include --remove-short-arcs in the batch file, as follows, the resulting IMG file gives an error in MapSource and appears empty to GPSMapedit although the IMG file size appears as 28MB in Windows Explorer.

java.exe -Xmx4000M -enableassertions -jar “c:\program files\mkgmap\mkgmap.jar” --route --remove-short-arcs=3 --description=“UT” --mapname=08250100 utah.osm

If I delete --remove-short-arcs=3 the IMG compiles with lots of Zero Length Arc errors, but loads into MapSource.

The Source OSM file is Utah State from Cloudmade.


Does it work as expected with the last stable version of mkgmap (1867)?

PS You can use -ea instead of -enableassertions (same command, just shorter)

Same problem with r1867 I’m afraid.

I use --remove-short-arcs without stipulating a value…does that work for you? What about difference values (5, 2.6, 10 etc)?

It doesn’t work without radius being specified either.

I should probably mention that I’m using a Dell PC running Win7 64.

I think the problem was with the cloudmade data. When I ran the same batch file on an extract from Geofabrik, --remove-short-arcs=3 worked fine.