Problem to login

New to OSM,
First, I created an account on the main page with “Gerhard” as name.
But the site (main page, lìnk on top right) didn’t let me log in, sayin “no user”
(Browser cookies enabled).

So I thought that I’d done something wrong, and asked for mailing me the pw. No response came.

Then I made an other acount, named “GerhardP”, plus changed the password.
I had to use an other mail account, and another name : the site says that my original name and adress already are used…

With this new email/name/pw, I also made accounts for this forum here,
and for the french-speaking mailig-list (they accept).

Allas, the OSM main page “login” link persists to say that I, “GerhardP”, don’t exist,
and offers to create a new account.
Is that kind’a “dead link” ? not implemented ?
New accounts… I’ll run out of e-mail-adresses, sooner or later…

I managed to upload two gpx tracks
(over there, it asks for e-mail adress as identification, not the name)
and found out that one has to put the file to upload near to the hard disk’s root,
not too far down into sub-directories,
and no french accentuation in the filepath nor in filename,
else the server says “wrong argument”.
Finally it worked, the tracks were added to the database,
but I didn’t receive an “email on completion” (that’s what it says, on “your GPS Traces” page, after upload).

Yesterday, nine time in ten tries, I could not acces to,
neither with safari nor with firefox (Mac OSX10.4.9).

Since this morning, I tried to upload an other track, but it said :
“POSIX error: Invalid argument” (NSPOSIXErrorDomain:22)
on page
Now it passed,
at about the seventh try, fourth re-boot, trying with safari and firefox.

I can’t pass hours and hours at trying to link to osm site…
Can anybody tell me,
where’s the hickup -
what I’m doing wrong ?
(I got no problems to contact other sites, wikipedia, mail, rss and so on : they run fine.)

Post scriptum :

Hello Gerhard, welcome to the OSM community.

I’m sorry that you’ve encountered so many problems. Lets try to solve/explain them:

You never confirmed your first account, so something went wrong during sending/receiving (or somewhere in between) of the activation email.

Yes, an account cannot be registered twice. Your second account has been activated though and you’ve used it to upload GPX files, so that one works.

Please try again, your second account (GerhardP) is active.

Yes, that behavior is a bit unfortunate and will probably change somewhere in the future.

I have uploaded files succesfully from 3 or 4 directories deep, can you be a bit more specific?

You should have received an email (at least I do), perhaps they are regarded as spam and are put in your junk mailbox?

Well, unfortunately, sometimes the servers are too busy which may cause problems. The project is growing rapidly and the software/servers are having difficulty keeping up with demand. Which subdomain from openstreetmap did you try to access? e.g. or

The POSIX error appears to be a Safari specific error (according to Google), so I don’t think this has anything to do with OSM…

Which subdomain on doesn’t work for you? What errors do you get? Can you elaborate?

Again, sorry that you are getting this much problems, but I hope this won’t deter you from contributing to the project :slight_smile:

I should have also mentioned: and use different username/password logins. So you have to register an account at both subdomains (if you want to). This makes things needlessly complex and perhaps a source of your confusion. Hopefully this will be fixed in the future…

Ok, I see… or think to see :slight_smile:
The “login/create account” on top right has nothing to do with using osm,
nor with the ability to consult the site - it concerns the wiki site system itself.
I didn’t know, pardon me.

Perhaps leave it as it is ? It works, as it is…

On MacOSX, one’s user-workspace is third or fourth level down, depending on the syntax one uses.
My osm files are down at level 10 and 11.
To upload a gpx to osm, I move it to the finder, and send it from there, that worx.
Perhaps this is a safari issue, too… I’ll use firefox, for osm…

I don’t think so, I use a local antispam that keeps spam in a separate folder,
I did’nt see something like wiki, osm or such in there.
But I’ll keep looking, next time.

Well, if it’s due to much people participating, that’s not so bad ! :wink:
Jam here started yesterday, using, no contact, no data download,
and five minutes later, I couldn’t get pages from .
I got no error msg at all, no “time out”, only turning wheel.
But… I don’t remember if that was via safari, or via firefox.
Seems to work, today :slight_smile:

So definiteley, I’ll use firefox for osm !

:slight_smile: nooo… :wink:
It seems that safari was the cause of most of the trouble I got.
Do you have other Mac users with safari ? They all right ?
I hope that with firefox things run fine now.
Thank you !

There are lots of other users who use a Mac for OSM. No idea though if they use Safari or not.

About the POSIX error: I used Google to see if it occurs not only with OSM and that appears to be the case, therefore I think it’s a Safari error. Nothing to do with OSM specifically.

Anyway, good luck in exploring OSM.

A “late note” for information :
My difficulty to connect seems to be due to trafic jam, it ain’t safari’s fault…
Wednesday june 20th, 21hr french local time, don’t answer : time-outs (firefox and safari)
and uploading with josm takes a loong delay.
Well, I hope that these are mostly people working on the map :wink:
and will come back later, or tomorrow…

Yeah, this is really bad. Sometime this evening the most important server decided to call it a day. Best thing is to try again tomorrow…

Hi there.

How do you know this kind of information? Are you on-site? Would it be possible to share this info on the Wiki front page please? Tonight I edited / added ~10 ways in JOSM and spent the next hour trying to upload them - the server just wouldn’t take them. It would help my frustration a little bit if I knew that the server was known to be straining under the load and people were actively working on the problem :slight_smile:

Thanks. -Ken

Well, there are several ways to get ‘in the loop’:

  • If some of the servers are not responding,
  • and/or if the munin statistics displays weird graphics of the servers behaviour
  • and/or people are complaining on the IRC channel
  • and/or people are complaining on the mailing lists

Then most probably something is borked.

For example: If JOSM is continuously reporting ‘timeout while connecting’ the best way is to save your changes to a local .osm file, go socialize with your family/friends or hang out on the IRC channel. You then can try again an hour(s) later or the next day. Usually things have been solved by then. When they do, just open the .osm file again and hit upload.

I’m usually on the IRC channel (passively) for most of the day.

PS. Short outages are most probably not noted on the front page of the wiki as it’s updated by hand. That status indicator is mainly to announce major problems/changes. I mostly use munin to monitor OSM’s status.

Hi, Lambertus,
That “munin” thing is a nice window to see into the machinery’s activity…
I dont’understan even 1 % of those abbreviations - but those graphs “talk”, themselves.
Wednesday evening,the site’s file usage touched 100%,
I suppose that was the reason why nothing passed…
Such “munin” info helps to stay cool, zen - and go “socialize”, as you say.
(It might be interesting to see if there is statistical correlation between osm overload,
and births in osm-er families nine months later… :wink:

Haha, when that happens OSM will become subject to a lot of social research I guess :slight_smile: