Problem resolving conflict with relation

I tried to make some changes using JOSM 1529. The upload stoped with an error message not really legible (the important last part was cut off so I saved my edits locally in an .osm file, then changed to JOSM 1566, opended my file and this time the error message was something like “provided version 620 of relation 13288, server has 621”.

OK, somebody edited that relation while I was doing my edits. Now how can I fix this? I tried editing the relation from the relations list. After clicking on “download elements” a message “there were some conflicts during download” occured and the relation showed in the list of conflicts. The box which appears after clicking on “solve conflicts” is kind of empty because the conflict is not with the tags but with the members of the relation. No help here.

After reading another recent thread here I changed to JOSM 1567, inserted a dummy tag on the relation to give it a difference to the server version. This way it was possible to solve a conflict which I did. The problem is now that when I try to upload I don’t get the “provided version 620 of relation 13288, server has 621” message any more but a java.lang.NullPointerException.

Can anybody please help me? I’m really fed up. In between I even tried to manually alter the .osm file by deleting the whole … from the source code but that seems to be tamper-proof :slight_smile:

I’ve had about the same experience as you with 1529 and some inbetween versions. In the end I get fed up as well, and just started over with my edits.

I must say that since 1561 all’s been going well for me, but I try not to do multi-hour editing sessions before uploading.

Hm, that doesn’t sound very encouraging.

I’ll probably need another day or two to get used to the idea that I spent half the night in vain and then do all the edits once again. Surely will then stick to the rule uploading changes every 5 minutes.

thanks anyway

I saw something regarding conflict management on the JOSM mailinglist yesterday. I think the newest versions are going to handle conflicts better…

1569 doen’t do it either but I found the topic on the bug list.