Probably a dumb question, but...

I downloaded the UK dataset from, file name was osm_generic_windows.exe.

I installed this to the default location - C:\Garmin\Maps\OSM generic routable

I ran Basecamp (version 4.1.2), selected “OSM generic routable” from the dropdown and I can only see a white square in the middle of the map view

What have I done wrong :slight_smile:

This is a Windows 7 PC - All Admin rights,etc.


I tried the Control G cache thing and also changed the map display scale to ensure I was looking at the right location.

Seems that BaseCamp does not display anything until some data is entered into My Collection. I imported a KML route and the underlying map information was then correctly displayed, for the whole of the Map View.

Is this a bug in BaseCamp ?

Maybe you’ve switched on the Basemap with Control G, pressing another time ctrl G might help

Well, I thought I had tried that

But now it’s working OK, pressing Ctrl-G does have the same effect

Thanks for the reply