Potlatch2 error

This is a german firefox4.

Can anyone fix this [object Object]?

This behaviour is also in a german IE8. The correct text is only shown for a few milliseconds at startup. In earlier versions of P2 it was displayed right.

See http://trac.openstreetmap.org/ticket/3674 … still open!

Still open because no-one has managed to yet provide steps that Andy (who’s worked on all the i18n stuff) has been able to reproduce.

Hi Richard,
what do you mean with “steps” and “Andy been able to reproduce”
I guess this “Object object” magic feature is not just related to Geman or local language?
How can I help? With screen shots - so the programer can see it?

This ObjectObject is not just a “nice to have”. I’d say it is a major bug and nuisance since one year


Only a few steps are to go:
Run window xp (I did it with german installation)
start a browser (ff or ie)
goto osm.org
press “bearbeiten”
you will see for a part of a second tracks, then object object

thats it.


If it were that easy we would have fixed it by now! No developers have been able to consistently reproduce the issue on their machines.

Maybe you could look at the source and find out what’s going wrong?

The same happens in Finland with Windows XP and Firefox 6.0. The button shows “GPS Data” first but after the map window has turned to show a beige background colour and before the POI icons appear the button text moves to “object Object”. It does not irritate me, though.

Sorry, I could be able to read source code, but I could not debug and understand it…
JRA describe too, when the change of the button happens.

Today I deleted some cache folder of Firefox especially the one from flash player. Then P2 started only without loading osm-data and displayed all buttons and icons right.

After I deleted the cache with Firefox menue P2 started with osm-data and changes button as JRA describes.

Maybe this helps at debugging.