Potlatch 2: fatal error

I have a fatal error in Potlatch 2. Help me please!
When I tried to cut a way in two pieces, the toolbar stopped working. When I move the mouse, the toolbar goes with it blocking the Save button.
So now I cannot save anything. What should I do?


Uploaded with ImageShack.us

Can you reproduce this?

Open a new ticket at http://trac.openstreetmap.org (use your OSM login data) and choose the component potlatch2 for the ticket.

Did you already have a look at http://wiki.openstreetmap.org/wiki/Potlatch_2 → Feedback and Bugs ??

Thanks for the answer. The bug has already been reported by another user.
I am waiting for the solution, now I quit working with OSM/Potlatch for a while because the error keeps coming back. Maybe it is due to speedy clicking but I don’t know.

What about editing with JOSM or the newly released Merkaartor 0.17 ??

stephan75: generally I find sandpapering my eyeballs to be less painful than working with JOSM :stuck_out_tongue:

West Erop: if you can provide us with steps to reproduce the problem, we’ll fix it. Right now we can’t fix it because we can’t reproduce the problem.

A bit more information about the problem. I used Google Chrome, now I use Internet Explorer 8 and the processor blocked when I hit a node/point. This time I could press the Save button so perhaps the problem is due to a Flash script in Google Chrome.

Edit: I tried to merge two ways, the toolbar blocked and now I cannot save in IE. &#^%& I quit.

Is there cut tool in JOSM?
Often I need to cut way in two or three pieces for add bridge , but I can’t.
finally for solve that,I delete the way and draw again in 2 pieces

Is there cut tool in JOSM?

Select one or more nodes
Tools… Split way.

thanks !!!:slight_smile: