Osmarender Rendering Problem - blank .svg file

Hi @all OSM members,

It’s been 3 days that im trying to render .osm data with osmarender and it still doesn’t work.
When i start processing in cmd with
java -cp C:\osm\xalan-j_2_7_1\build\xalan.jar org.apache.xalan.xslt.Process -in osm-map-features-z13.xml -out map.svg

He starts processing converts everything into the map.svg but when i try to open it i’m always recieving the .svg frame but with nothing inside…
(when i klick on sourcecode there is content, also tried all the other .xml files)

When i’m using Firefox to visualize the same osm dataset it works

Hope anybody can help me. I’ve checked everything at least 3 times…

I have installed

  • jdk1.6.0_17
  • xalan-j_2_7_1
  • all osmarender files from the Subversion-Rep (osmarender.xsl, all .xml stylesheets)

osm dataset is named data.osm (default)
checked also the xalan build.bat via CMD everyrthing works (javac compiler, roots, classpaths etc.)

OS is Windos Vista

Thx for any suggestions or help in advance


Hi Chico,

the only xslt processor I could get working first time was XMLStarlet and I’ve not gone back to try and get the others working. I have no idea what the differences are between them and it seems to do the job so I stuck with it.

I was using Vista and I’ve just installed it on my Win7 laptop from scratch and it works fine. It took me ages last time, if I remember!

I use JOSM to download the data and just saved it as data.osm, ran xmlstarlet as per the Howto and it was fine

I thought I might blog getting it running as it wasn’t easy last time, but it’s taken about 30 minutes including all the software downloads. See my diary http://www.openstreetmap.org/user/Seventy7/diary

Hope this helps.

Hi Seventy7

Thanks for your answer and your blog link. I always converted everything without problems with linux so im quite sure it depends on Vista. I’ll try XMLStarlet soon and give you feedback.