Osmarender Error: The system cannot find the path specified


I’m trying to use Osmarender to generate a map.svg from a small local area.

I’ve tried to follow the instructions on the Osmarender/Howto page, trying nearly all of the Windows options.
The xml and xsl files were downloaded and placed in the C:\temp folder (see below)
The data.osm was downloaded using JOSM.

However an error occurs with each method.

Here is an example console copy and paste with msxsl:

Directory of C:\Temp

08/02/2010 09:49 AM .
08/02/2010 09:49 AM …
08/02/2010 09:43 AM 492,076 data.osm
08/02/2010 08:51 AM 314,317 osm-map-features-z17.xml
08/02/2010 08:51 AM 201,604 osmarender.xsl
3 File(s) 1,007,997 bytes
2 Dir(s) 427,073,830,912 bytes free

C:\Temp>msxsl osm-map-features-z17.xml -pi -o map.svg

Error occurred while executing stylesheet ‘file://C:\Temp\osmarender.xsl’.

Code: 0x80070003
The system cannot find the path specified.

I get a similar error with XRay2. The other methods give other errors.

Any ideas?



I have the same problem. I have tried several xsl processors, several different data sources, two different zoom levels. For any combination, the same result.

I cannot help you directly with that osmarender issues, but there are several other rendering programs that can produce svg files from OSM data for small areas.

Are you interested or is it fix to osmarender?