OSM not Routing Along a Road as it Thinks it's One-way

Why does OpenStreetMap think the road to the roundabout is one-way (in the wrong direction) and not route along it? Here is an example route where it incorrectly routes around the block:


I tried removing the road to the roundabout and putting it back to see if that would somehow fix it, but it still won’t navigate along the road. Changeset here:


You need to wait at least 2-3 days for the data to update for that specific routing engine, and it is likely not different for the other options. See at the bottom of About routing.openstreetmap.de

I had a look at your change, it is not helpful to first delete a road and then add a new road like the one deleted.

Before, the road that was deleted it as tagged with:

maxspeed=30 mph

No oneway=yes, that was already removed in a changeset you also commented on.

As to why the routing link that you shared is not working, I tried the “Reverse direction” button and that was not working also so oneway is not the problem. Then I tried another router that I know updates the routing data every 24 hour and that routes fine. Then saw you can also select other routers in the link you shared and I see also no problem with GraphHopper.

So the problem seems to be with OSRM, it could be that the data is too old, it could be there is another problem.

1 Like


That was correct, I was unaware the routing engine lagged behind the map by a few days.

Car (Valhalla) and Car (OSRM) are now routing correctly, therefore the issue was due to routing engine taking 3-4 days to update.

Car (GraphHopper) is still currently incorrect, however it’s likely they just have a slower update cycle and it will correct itself in time as well.