Openstreetamp in oracle Mapviewer

Hi All,

I am new here .

I was trying to integrate openstreetmap with oracle Map Viewer, so that we can use it in OBIEE analytics reports.

Can anyone please tell me how to do this?

I suppose you must first get some OSM data into Oracle. I would experiment by downloading some data in .pbf format from Geofabrik and converting data into Oracle with GDAL program ogr2ogr. Read

You may be interested in how-configure-osm-in-oracle-mapviewer-11g

Hi ,

Thanks for your help.

I have been able to integrate openstreetmap in oracle mapviewer.
But its displaying map only for europe.

Can anyone you please let me know which WMS url I should be using if I want to display World Map?
also which SRID should be used with that wms.

Thanks in adavance.


What are the parameters you gave to Oracle mapviewer in order to display an OSM based map?

It is better to tell us in detail what you have tried so far … so maybe we can help you better.

Hi Stephan,

Thanks for your reply.

I think the WMS url which I used provides only map for Europe. So I need a openstreetmap WMS for World map.
along with the parameters to be used.

required parameters are :

external_map_source url:

Adapter properties :

     <property name="service" value="???"/>
     <property name="srs" value="???"/>
     <property name="layers" value="???"/>
     <property name="map" value="???"/>
     <property name="format" value="image/png"/>


coordinate_system srid= ???
minX= ???
minY= ???
maxX= ???
maxY= ???

Please find below the parameters I have used in xml format :

<map_tile_layer name=“OPENSTREET4_PROXY” image_format=“PNG” http_header_expires=“168.0” concurrent_fetching_threads=“3”>
<external_map_source url=“” request_method=“GET” timeout=“15000” adapter_class=“mcsadapter.WMSAdapter” adapter_class_path=“/BI/obiee11g/Oracle_BI1/bifoundation/jee/mapviewer.ear/web.war/WEB-INF/tileserver/adapterlibs/MVDEMO.OPENSTREET4_PROXY.jar” proxy_host=“” proxy_port=“8080” transparent=“false” clipping_buffer=“0”>

<tile_storage root_path=“/BI/obiee11g/Oracle_BI1/bifoundation/jee/mapviewer.ear/web.war/tilecache/MVDEMO.OPENSTREET4_PROXY/”/>
<coordinate_system srid=“4326” minX=“-180.0” minY=“-90.0” maxX=“180.0” maxY=“90.0”/>
<tile_image width=“256” height=“256”/>
<zoom_levels levels=“10” min_scale=“1000.0” max_scale=“2.5E8” min_tile_width=“6.114410817072114E-4” min_tile_height=“120.0”>
<zoom_level level=“0” name=“” description=“” scale=“2.5E8” tile_width=“120.0” tile_height=“120.0”/>
<zoom_level level=“1” name=“” description=“” scale=“6.2830265E7” tile_width=“36.0” tile_height=“36.0”/>
<zoom_level level=“2” name=“” description=“” scale=“1.5790569E7” tile_width=“9.473684210526315” tile_height=“9.473684210526315”/>
<zoom_level level=“3” name=“” description=“” scale=“3968502.0” tile_width=“2.4161073825503356” tile_height=“2.4161073825503356”/>
<zoom_level level=“4” name=“” description=“” scale=“997368.0” tile_width=“0.6091370558375635” tile_height=“0.6091370558375635”/>
<zoom_level level=“5” name=“” description=“” scale=“250659.0” tile_width=“0.1532567049808429” tile_height=“0.1532567049808429”/>
<zoom_level level=“6” name=“” description=“” scale=“62996.0” tile_width=“0.03851503156092864” tile_height=“0.03851503156092864”/>
<zoom_level level=“7” name=“” description=“” scale=“15832.0” tile_width=“0.009680281803759176” tile_height=“0.009680281803759176”/>
<zoom_level level=“8” name=“” description=“” scale=“3978.0” tile_width=“0.002432300956705043” tile_height=“0.002432300956705043”/>
<zoom_level level=“9” name=“” description=“” scale=“1000.0” tile_width=“6.114410817072114E-4” tile_height=“6.114410817072114E-4”/>


Hi guys,

I’m new to maps, Openstreetmaps and Oracle Mapviewer.
I’m trying to import an external map tile layer into Oracle mapviewer using Oracle Maps API.
I tried the code here but it doesn’t display any maps.

Looking closer at the code, I noticed the function function getOSMMapTileURL(tx, ty, tw, th, level) has some parameters, but when it’s called here:
var osmBasemap = new MVCustomMapTileLayer(mapConfig, getOSMMapTileURL);
no parameters are used.
What are tx, ty, tw, th and how are they defined?

I also tried in the browser the URL"+(level)+"/"+x+"/"+y+".png after replacing x, y and level with some dummy data. I don’t get any reply.

Can you help me on this?


If I am not wrong, the OSM tile servers starting with “tah” (Tiles-at-home … see OSM wiki) are no longer available.

Be sure that you use a valid source URL for any OSM based tiles, see