Not receiving followup email

I’ve been trying for the past hour and a half to get a selection of tiles downloaded for my area. It says it sent me the first email, which it does. I click the link in that email and it says I’m in a queue of <5 people. I wait, check the link again a few minutes later and it says I’m no longer in the queue and that my email must be on its way. I wait, and it never comes. I have tried my normal two gmail accounts, an outlook account, and a limited time randomized email. I simply cannot get the download link for my selected tiles.

If you could provide any help, that would be VERY appreciated!!

i have the exact same problem

I have received the first email and when I click the link I’m taken to a page that tells me that it is no longer valid and that the most likely reason is that my job has already left the queue. I wait for the follow up email that will take me to the files and no email arrives.
I made two separate requests, one for an OSM and the second for an OCM map. It is now some 18 hours later and still no follow up email. Something is broken.

I’ve just tried again. This time I was told that my request was number 2 in the queue and the wait time was approximately 12mins. Barely a minute later, the message was “This request could not be found in the queue. Most likely the map is already generated and you received another email containing the url where the map can be downloaded, or you should receive that email shortly.”
That was more than 20 minutes ago and still no email. I’ve checked my ISP’s mail server and they’re not being stopped by a SPAM filter.

This is displayed on the page
Server status:, queue = 746 requests (~3.1 days), status = OK, queue = 2 requests (~0 days), status = OK not available!, queue = 1 requests (~0 days), status = Disk full

The Map version data is from 30-06-2016.

I guess Lambertus is busy getting it up and running and we all appreciate the great service that Lambertus provides on this site.

I suggest you wait until the end of the week or try another service for now…

EDIT: Further info here