Node cache size is too small to fit all nodes


I am trying to import britain.osm

I used:
osm2pgsql --password E:\data_dir\DATA\OSM\great-britain-latest.osm.pbf -d britain_osm -U postgres -P 5432 -S --hstore

I enter the password, then get an error:
Processing: Node(48590k 4049.2k/s) Way(0k 0.00k/s) Relation(0 0.00/s)
Node cache size is too small to fit all nodes. Please increase cache size

Could anyone please share where to increase the Node cache size for PostGIS??
Any assistance appreciated.



Hi Clive,
for import, osm2pgsql has to either keep all the nodes in memory or use a flatnode file.

As you are not using the flatnode option, you seem to be running out of memory. So you either have to increase the memory of your machine or use the flatnode option - I would recommend the latter.