No Windows installer released for JOSM v18193

JOSM is begging me to update from v18118 to v18193, but when I go to and download the update, the version linked to is still v18118. What happened, and where’s the link to the Windows installer for v18193?

Version 18118 is very old.
Download and use the windows installer:

(see below)

Don’t use the other options!

There is a problem on older java versions (java8) with the installer, as it changed and delivers java16 now. Please, uninstall the old JOSM version first and then install the new JOSM version. I hope, preferences are not deleted by uninstall but you might want to make a backup.

Yeah, I tried that, and I ended up getting the installer for v18118. The installer for v18193 is not posted through that link.

One of the typical pitfalls is that the Browser doesn’t overwrite an existing josm-setup.exe, instead it creates a file josm-setup(1).exe
So, make sure that you use the newest download (or remove josm-setup.exe first)

I have been following this link, <>, and Google Chrome shows me exactly what I am downloading and provides me a link to the very file I am downloading. Still, the installer I got was for v18118.

I get v18193, so the installer contains the right version.

Probably you have an old installer or old version in your PC which is invoked instead of the new version.

[color=#090]Issue resolved[/color]

Interesting… That actually worked. Now my version of JOSM is updated to 18193.

You are welcome.

Could you please, add [solved] to the title and maybe add the link to the solution (
You can do that by editing your first comment. Thanks.