No roads near starting point

I get this message when I use my Garmin 60cx - Follow Road. It was working fine a month ago. I generated a new map and it’s still doing it. It’s working fine in “Off Road” mode. Can someone help me?

I suppose you have downloaded a route-able map.

Check that the new map is displayed, the 60cs base map is very limited and does refuse to route if you are to far from a mapped road.

I suppose you realise the unit will not follow road until the map is drawn.

The new map could be corrupted, download a fresh copy and try again.

Generic Routable (new style) from are working OK for me on a Garmin 60csx.

Get back if none of the above help.

I’ve requested a new one but am 500+ in the queue so it might be a day or two before I can get back to you. Thanks!!

2.2 days - wow, that sure has increased. I guess I better get maps way ahead of time.:rolleyes:

I’m not sure whether is a reliable source for maps now. Its administrator is not responsive since a year or so. Please try to download a routable map from one of the other sources mentioned on

… or create your own. There are a bunch of examples of how to do that around, and I also wrote one at .

I finally got a new osm_generic_gmapsupp zipped file. I have loaded it to the GPS (Garmin 60Cx) micro-SD card then extracted it. I have left the image file in the folder and I’ve taken it out of the folder. No matter what I try I get the same error message when I try to follow on the road: No roads near starting point. I’m beinging to wonder if my Garmin is the problem. Any other suggestions?

I have now downloaded a map from Basecamp and I still get the message No roads near starting point. So Basecamp and OpenSource don’t work. Is it my 60Cx?