New Zealand Routable Garmin Maps do not work

Hi, I have been trying to get New Zealand tiles to work in MapSource. I just downloaded the latest build (29-09-2010) using the dropdown for Oceania/New Zealand which yields these tiles: NZ-Dunedin; NZ-Auckland; WS-Apia; NF-Kingston. I have achieved the best results so far, however there are still problems. In MapSource, the north and South Island of New Zealand show at 700, 500 & 300km scale, however as I zoom in, it disappears. I tried downloading just one tile and it exhibits the same behavior.

Any ideas as I want to plan a bicycle trip in New Zealand and would like to have this working.




I just installed the New Zealand map too and the way MapSource (6.13.7) shows it is truly bizarre.

<100m and >200m shows nothing, so I have only two resolutions that show anything… :?

If you have a Garmin GPS and you want to cycle in NZ May I suggest this map:

It contains pretty much every lane and alleyway with names and most of them even with house numbers. Routable and searchable.


Yes, NZ has excellent free maps from alternative providers :smiley:

I have the same problem as described above by petersfreeman! Can anybody help me because I need the maps for my car trip through NZ! Thanks a lot!

See for instance this old discussion.

It took a while but it seems like this bug has finally been fixed recently around Mkgmap version r2630. Current and newer maps should be alright near the -/+ 180 degrees meridian.

At least it seems to work in MapSource, but Basecamp still doesn’t show a map :rage:

New Zealand seems alright, but the Fiji islands are still not showing up…

For Fiji, the minimap in MapSource does show map features while the main map remains to show the faint yellow background. I can’t find anything in Basecamp.

Not the solution, but may be a hint:
I observed also empty areas at some places and some resolutions. Some tests gave the following result: The behaviour depended on the parameter --max-nodes in splitter. A high number (1 600 000) resulted in empty areas, with a low number (–max-nodes=300 000) the map was OK.