new OSM map features not appearing in downloaded Garmin maps

I love this website and being able to contribute with map updates, then downloading new maps and seeing the changes.

However, changes I made just after Christmas are not appearing in downloaded Garmin maps. I even force a custom tile selection to make sure it is a “freshly produced” map, but the new features are still not there.

I can see them in JOSM, and in the “slippy map” (?) at - but not in MapSource viewing a recently downloaded and installed map.

An example feature is Weir Rd (way 549698673)

Anyone have any ideas what I’m doing wrong? (this has worked for me many times before)


I guess you are using this site for your garmin suitable maps…
Free maps for Garmin brand GPS devices
At the bottom right of the blue map on that page you can see the last date that the maps were updated and that is before your edits to the were done.
So you will need to wait until the site updates the maps.

There are many providers of Garmin suitable maps that derive their data from the database.

ah - I understand now

thank you