New JOSM Plugin integrates OpenStreetBugs


I have written a JOSM plugin, which integrates OpenStreetBugs into JOSM. The plugin can be installed on the plugin tab in the settings dialog.


I have some problems after trying to install your plugin. After JOSM restart I got:

I am using version 1042 of JOSM, if it helps.

Sorry for my late response, but the forum doesn’t seem to send response notifications.

I need a little bit more information. Could you try to start JOSM from command line? Open a console, change to the JOSM installation directory and run

java -jar josm-latest.jar

. Then there will be some output, which could help to find the error.


There you go:

D:\Downloads>java -jar josm-latest.jar
Could not get presets icon presets/boule.png
Could not get presets icon presets/boule.png
loading AgPifoJ
loading openstreetbugs
org.openstreetmap.josm.plugins.PluginException: An error occoured in plugin openstreetbugs
        at org.openstreetmap.josm.plugins.PluginInformation.load(
        at org.openstreetmap.josm.Main.loadPlugins(
        at org.openstreetmap.josm.gui.MainApplication.main(
Caused by: java.lang.NullPointerException
        at java.util.Properties$LineReader.readLine(Unknown Source)
        at java.util.Properties.load0(Unknown Source)
        at java.util.Properties.load(Unknown Source)
        at java.util.PropertyResourceBundle.<init>(Unknown Source)
        at org.openstreetmap.josm.plugins.osb.i18n.Messages.loadBundle(
        at org.openstreetmap.josm.plugins.osb.i18n.Messages.<init>(
        at org.openstreetmap.josm.plugins.osb.i18n.Messages.getBundle(
        at org.openstreetmap.josm.plugins.osb.i18n.Messages.translate(
        at org.openstreetmap.josm.plugins.osb.gui.OsbDialog.<init>(
        at org.openstreetmap.josm.plugins.osb.OsbPlugin.<init>(
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at java.lang.Class.newInstance0(Unknown Source)
        at java.lang.Class.newInstance(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginInformation.load(
        ... 2 more

Are you using the latest version of my plugin? It seems to be a problem, which has been fixed lately. Under which language is your system running? Anything other than english or german?


It looks like JOSM downloaded an older version of your plugin and everytime I tried to activate it it used that version. I donwloaded the latest version from the website and put it in the JOSM plugins directory and it works now.