New Bee - Really confused

First sorry if this has been posted, answers dealt with, but at the moment I am really frustrated (so lets first blow some steam).
I have gone over to the WIKI to find a solution to my issue (come to it a little later), didn’t find an answer so dis a search couldn’t find and answer (I may be dummy … though i don’t think so ) so wanted to send a message to some admin. went to the admin page and got a bunch of names/function, well selected the guy in-charge of WWW . cant find who to send a message.
Now back to the point.

When I login I get presented with a non English local (he). This seems to cause trouble (seen it in a bug report). I get
“The OpenStreetMap server encountered an unexpected condition that prevented it from fulfilling the request (HTTP 500)
Feel free to contact the OpenStreetMap community if your problem persists. Make a note of the exact URL / post data of your request.
This may be a problem in our Ruby On Rails code. 500 occurs with exceptions thrown outside of an action (like in Dispatcher setups or broken Ruby code)”

for may of the links. How do I get to change my local to English. Trying to get n the “my settings” (assuming I may find there something to help) fails with the above message.
An other issue is how do you remove a bad uploaded trek!

Need assistance to be able and mange any trek I would like to up load,edit and have published.


The locale is determined by your browser. Assuming you’re using Firefox on Win, you can change your locale in “Tools > Options> Content” and then click on the button that says “Select” in the “Languages” section. You would then add English and put that on the top of your list.

You can delete a track when you are logged in, and then go to . Click on the track you want to delete, and click on the button that says “Delete this track”.

This will all work when you manage to log in. I don’t know however if changing the locale will prevent you from seeing this 500 error. Good luck!

(The names of the menus might be different as I’m not using Firefox in English, but you get the idea)

Hi Emilien,
I have don’t what you proposed (change the order of the languages) I even went one step further and remove from my list Hebrew, remove the openstreetmap cookies and did a re-login. when not loged in I get presented with all English interface, the moment I am in (login) I get a Hebrew and English in the interface (I assume not all was translated). From that I understand that some of the language info is in the OSM DB and I would like to change that, as stated previously trying to get in to “my settings” yield a the HTTP 500 error. So I am stuck :frowning:

P.S. I understand the OSM team is heavily over loaded with work and are doing a super job but a “help desk” would be great. ( not the type you see in some pleases that give you canned replays)

Probably the quickest way to get help is to ask on the IRC channel. Details here:
There’s usually a few administrator people there.

Or if you think there’s a bug in the website, then post a ticket on trac:


I’m sorry you are still getting the 500 error. As I’m no part of the OSM team, I hope somebody will be able to help you.
If I get it right, you can log in but still see some strings in Hebrew, which is strange if you have removed Hebrew from your languages list… I suppose your profile is set up with the Hebrew language, and you would indeed need to go in your profile to change that.

Changing OSM data has nothing to do with going in your profile, so I don’t really understand what you want to do. If you want to edit the map, you don’t need to go to your profile, insteas click on the “edit” button/link that appears on top of the map. If you are not yet very familiar with OSM, I would recommend reading the tutorials (very good/interesting in my opinion):

If you want to translate the website, then you need to go to read about translatewiki

Vcalw thanks went over to the IRC and the fixed the problem on line :slight_smile:
now it work.
Emilien thanks for the help and time
There was a problem with the site. in my profile there is a setting for language and I wanted to get to it in-order to change i to English. Many of the options and links were failing


P.S. - this is fixed and resolved

Cool, nice to hear that the problem got fixed.