My first 3D OSM building - experience sharing and questions

Hi all,

as the topic states I created my first 3d building in OSM. I went with a local church so maybe not the easiest building to model.

I’m using ubuntu as my OS so I couldn’t get SketchOSM to work on my PC. After a lot of attempts I got sketchup 2017 to work but the extension wharehouse isn’t available so I can’t install SketchOSM.
Q1: Did anyone succeed in getting SketchOSM to run on a linux machine?
I went with JOSM and the Kendzi3D plugin to model the building. This can be a bit frustrating sometimes because Josm clearly isn’t designed with these 3D models in mind. But I persevered and learned a few tricks. Is my main source of information but it’s not a lot. I would have liked something that can guide me through with baby steps.
I also found this youtube video: Although Igor doesn’t explain what he is doing it’s still a great help.
Q2: Are there other videos/tutorials that can help me as a beginner?

Problems with my model:
There is a big difference between how renderers handle the roof direction of the skillion. Kendzi3D snaps the direction to a main direction so you only have 4 directions (top to bottom, bottom to top, left to right, right to left) but osmbuildings and F4map is the real 360° direction. This makes it difficult to model it correctly in Josm. Also this:

from: doesn’t work.
Q3: Which renderer is the most correct renderer? what should I focus on? How do I find the correct direction?

At the back of the church I have a half circle. I the osmbuildings renderer this is almost what I want to have. But F4map does something completely different.
Q4: can someone help with the half circle at the end of the roof? What is my best option to handle that?
OSMbuildings gableds the hipped roofs and F4maps hippeds my gabled roofs. Why do these renderers act different for the roofs?
Q5: how do I fix this? + see Q3.

building height
I committed the crime of mapping for the renderers. I lowered the building height because otherwise it renders over the building parts. according to the wiki:

but that doesn’t seem to be the case for my model.
Q5: What am I doing wrong here? Can someone help me?

Thanks in advance for the help.
Best regards,
Frans Napaters

congratulations! great job!

If using sketchosm in a win10 virtual machine is an option you can download images from Microsoft

Okay, first: Nice work. You could look at Moscow for example.

There is not “the most renderer”. The ones available focus on different things. For roof direction just use (found through simple3d buildings).

The thing for the renderer: Well, now you have ONE 3D renderer who shows it correct. Every other renderer will show it probably false. Tag it as correct as possible and provide these examples for the renderer, maybe its possible to find a solution.

For the building:part=* i guess you are talking about osmbuildings? If yes delete the wrong height. You can put your issue for osmbuildings in at least. Its about that problem: buildings:height=* should be ignored if a building:part=* is present.

Best regards

Sketchup doesn’t want to work in virtualbox. It doesn’t want to work with the virtual GPU. I haven’t tried VMware player but I think I will stick with Josm/Kendzi3D for now.

I will add the correct directions using this method. It’s more work but at least I’m certain it will get rendered correctly.

Both F4 and OSMBuildings still render the building itself. so it’s not only the OSMBuildings renderer. I will add to the issue in github.

Thanks for the feedback

Win 10 Sketchup make 2017 do not load existing 3D building that are in OSM,
only de 2D flat map. with the ground shape …
Someone any trick …

reporting on some more progress:

I added the directions of the skillion roofs in degrees. JOSM shows the degrees if you draw a line so I drew a line for reference and used those to add the roof direction. This solves the roof directions issue in both F4 and osmbuildings. lessons learned: Always add roof direction to skillion roofs, even if your primary renderer renders them correctly.

I created the building relations in JOSM (which wasn’t easy as a beginner user of JOSM. I will try to create a guide next time) This solves the issue in OSMbuildings but not in F4. F4 still renders the parts of the building I didn’t fully cover. Leaving paper thin walls up to the major building height. I will need to cover every square cm with building parts. I think if I do that I will not need the relationship anymore. Lessons learned: cover every square cm of the building outline.